HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Sketchfab icon not appearing

This discussion is related to the Sketchfab addon.
okhawajaokhawaja New
edited August 2016 in Vanilla 2.0 - 2.8

I am using Vanilla 2.2, Advanced Editor 1.7, Bootstrap Theme, and I have 30+ other plugins enabled. I am using HTML for Advanced editor desktop and Tex for mobile. I just wanted to try the SketchFab plugin, but after enabling the the plugin, icon for Sketchfab doesn't appear in my editor. If there is no obvious reason for why the icon won't appear for me, my only option is to disable a plugin one by one to see if it is a plugin interfering.

Tagged:
vrijvlinder

Comments

  • I just tried this plugin with Bittersweet theme and same issue: the sketchfab icon doesn't appear in editor window..... @Sketchfab

  • RiverRiver MVP
    edited August 2016

    check your console for errors and see if the css file is being read.

    then fix it in the plugin if the plugin css is not found.

    /plugins/....... in the add css has to match the case exactly or of the folder.

    then start a new question when you run into the next problem about the icon in the wrong place.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinder
  • I have no clue what you mean....I have no errors in the console.

  • Just disabled all my plugins except Advanced editor and SketchFab, tried Baseline theme as well. It just doesn't appear...Plugin needs to be fixed.

  • @River is it working for you?

  • RiverRiver MVP
    edited August 2016

    @okhawaja said:
    @River is it working for you?

    I don't use it, I just see the code appears to be broken because it is upper case in some places and not others.

    it will probably need other changes.

    1 - search for the plugins folder.
    2 - search for the sketchfab plugin
    3 - edit the class.sketchfab.plugin.php
    4 - change 'plugins/sketchfab'); to 'plugins/Sketchfab'); in two places.
    5 - if it doesn't work - mark the plugin as broken.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinder
  • The css file and js file were lowercase named like you said, so I fixed those 2 and now it shows up in plugins inside console, but still the icon doesn't appear and no errors in console. The css is loading in console.

  • RiverRiver MVP
    edited August 2016

    lol

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • GOT IT TO WORK!!!!! >.< there are parts inside the class.sketchfab.plugin.php that have to remain lowercase and other parts have to be upper case....The file/folder names should be uppercase Sketchfab and echo '';

    has to be lower case......Thanks @River

  • Here is the working file with the proper casing if anyone wants.

    vrijvlinder
  • RiverRiver MVP
    edited August 2016

    @okhawaja said:
    there are parts inside the class.sketchfab.plugin.php that have to remain lowercase and other parts have to be upper case...

    yes, the steps remain the same, not sure why you were changing other things.

    edit the class.sketchfab.plugin.php
    and in the class.sketchfab.plugin.php change 'plugins/sketchfab'); to 'plugins/Sketchfab'); in two places.

    as mentioned above. https://vanillaforums.org/discussion/comment/242930/#Comment_242930

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

Sign In or Register to comment.