Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6.1 is here with critical security patches. One of them has been publicly disclosed.

Advanced Editor: Upload not possible in several Browsers

tchncstchncs Germany New

Hi there, i already created an issue on Github several months ago but it is not there anymore?
Is this why there was never any response? There should at least two issues from me.

However, often users reported a broken upload feature in the Advanced Editor.
In this case, there is just a link to markdownify an image without an upload option.
In the case of the issue i was able to reproduce this on webkit based browsers but not in Firefox.
Ironically also a Firefox user reported this to me.

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    So dragging the image into the editor results in failed upload?

  • RiverRiver MVP
    edited September 2016

    @tchncs said:
    Hi there, i already created an issue on Github several months ago but it is not there anymore?
    Is this why there was never any response? There should at least two issues from me.

    However, often users reported a broken upload feature in the Advanced Editor.
    In this case, there is just a link to markdownify an image without an upload option.
    In the case of the issue i was able to reproduce this on webkit based browsers but not in Firefox.
    Ironically also a Firefox user reported this to me.

    can you produce a screenshot or get the users to produce a screenshot.

    and also show one with a js console to see if there are any errors specific to the bwoser that produces the error.

    you mean this one.

    https://github.com/vanilla/vanilla/issues/4283

    pretty hard to debug without seeing an image. next time ask your users to take a screenshot of the issue.

    you didn't say what formatter you are using (wysiwyg, markdown, etc.)

    if there is just a link to the image - usually it is a permissions issue where you don't have permission to upload.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • tchncstchncs Germany New

    Sorry for my late response.

    So dragging the image into the editor results in failed upload?

    can you produce a screenshot or get the users to produce a screenshot.

    As i tried today, the drag&drop field was blank randomly and i was unable to choose a file to upload but drag&drop worked.
    This behavior was in Firefox and Chromium.

    After uploading a file, it was back there.

    I got a screenshot:

    He is also unable to drag&drop. Firefox.

    and also show one with a js console to see if there are any errors specific to the bwoser that produces the error.

    I need to ask when he is back so i get it with console log.

    you mean this one.

    Oh, i'm sorry, i searched issues by author on github but it didn't showed me anything.

    you didn't say what formatter you are using (wysiwyg, markdown, etc.)

    Markdown

    if there is just a link to the image - usually it is a permissions issue where you don't have permission to upload.

    Good point, i need to check this.
    But then i wonder why myself, as admin was sometimes unable to upload anything like in the userscreenshot.

  • tchncstchncs Germany New

    Ouh...forced to doublepost again... .
    I tested with a second account and it seems like a permission problem.
    Sorry for wasting your time.

  • tchncstchncs Germany New

    Someone sent me a screenshot, it is not fixed for everyone yet so it seems like it wasn't just my fault:

    daocaoit
  • RiverRiver MVP
    edited September 2016

    @tchncs said:
    Someone sent me a screenshot, it is not fixed for everyone yet so it seems like it wasn't just my fault:

    in the code there is talk of a kludge.

    this is just a warning message isn't it, not a fatal error.

    Are you sure the two are related. problem with upload and the warning.

    what browser was the user using? ask them and did they not see an option to upload, and did you check their role and permissions.

    https://github.com/vanilla/vanilla/blob/Vanilla_2.2.1/plugins/editor/js/editor.js#L661

    https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Stmt_after_return

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

Sign In or Register to comment.