Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Articles do not format the text correctly

This discussion is related to the Articles addon.

The article do not follow my bbcode format.
If I make any formatation on the article it do not work.
On the article comments all formats works, but not in the article.

Comments

  • ShadowdareShadowdare π Moderator
    edited October 2016

    I haven't tested the BBCode format with articles thoroughly yet, but can look into it. Does anyone else have experience with using this format with the Articles app?

    By the way, are you using the NBBC plugin along with the BBCode format or just the standard Vanilla BBCode format?

    Add Pages to Vanilla with the Basic Pages app | Publish articles with the Articles app

  • I'm using NBBC plugin.
    But just I tried change all the system to use CKEditor with wysiwyg and have similar problem. I guess maybe the plugin has some incompatibility with my vanilla 2.2.1 version?

  • ShadowdareShadowdare π Moderator
    edited October 2016

    Would you post some example BBCode text that doesn't work in articles, but does work in article comments and Vanilla discussions/comments? I'll test it out.

    Add Pages to Vanilla with the Basic Pages app | Publish articles with the Articles app

  • @Shadowdare , I guess in part I do not test with a good text before and also got a cache problem.

    Today I decide to try the CKEditor again with wysiwyg and most of the things are fine. With the bbcode most are fine to.
    The text I tryed yesterday I have big titles and many numbered lists.
    The lists are the one not showing for now with both wysiwyg and bbcode.

    But I look into the HTML code generated and the HTML tags for lists are there. It is just a CSS problem that I can solve my self.

Sign In or Register to comment.