Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
After February 6, this site will no longer have Facebook, Twitter, or OpenID sign-in options. Read our announcement about social media SSO support in 2.8 for more info.

Make sure you have a current, valid email address set in your profile and set a password so you can login without it. If you get locked out after that time, you can choose "Forgot Password" to fix it as long as a valid email is on your account.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Too many redirects error during setup

This discussion was created from comments split from: Vanilla 2.3 is now available.

Comments

  • SvetlioSvetlio New
    edited November 2016

    Hello, I am having difficulties with the new Vanilla installation as I get the too many redirects error after extracting the zip file and trying to proceed with the script setup.

    Here is the content of the .htaccess file:

    # Original
    # If you modify this file then change the above line to: # Modified
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        RewriteBase /vanilla_man
    
        RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&([^?]+))?$
        RewriteRule ^index\.php %1?%3 [E=X_REWRITE:1,L]
    
        # The basic rewrite rule.
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php [QSA,E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
    
        # Add the proper X_REWRITE server variable for rewritten requests.
        RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
        RewriteCond %{ENV:REDIRECT_X_PATH_INFO} (.+)
        RewriteRule ^index\.php - [QSA,E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,E=X_PATH_INFO:%1,E=!REDIRECT_X_PATH_INFO,L]
    
        # 301 redirect urls that start with index.php
        #RewriteCond %{REQUEST_METHOD} GET [NC]
        #RewriteCond %{REQUEST_URI} ^(.*?)/index\.php(.*)$
        #RewriteRule ^index\.php /%1%2 [QSA,R,L]
    </IfModule>
    
    <IfModule mod_headers.c>
       <FilesMatch "(?<!embed)\.(css|js|woff|ttf|eot|svg|png|gif|jpeg|jpg|ico|swf)$">
          Header set Cache-Control "max-age=315360000"
          Header set Expires "31 December 2037 23:59:59 GMT"
       </FilesMatch>
    </IfModule>
    

    Also, the access logs:

    IP - - [28/Nov/2016:12:55:06 +0100] "GET /vanilla_man HTTP/1.0" 301 247 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:06 +0100] "GET /vanilla_man/ HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:06 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:07 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:07 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:07 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:07 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:07 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:08 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:09 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    IP - - [28/Nov/2016:12:55:09 +0100] "GET /vanilla_man/dashboard/setup HTTP/1.0" 302 - "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14"
    

    Please advise on how to resolve the problem and install the application's new version.

    Best Regards,
    Svetlio

  • RiverRiver MVP
    edited November 2016

    https://vanillaforums.org/discussion/comment/244367/#Comment_244367

    if you have other software installed. try zipping it up and removing it - to see if it interferes

    try a different host. different OS, different webserver if possible.

    at the very least you want to provide your version number of php, your OS operating system, your webserver type.

    for a test:

    see if you can install with the version 2.2 .htaccess - modify it to your forum, if you use apache or some webserver that actually uses .htaccess

    https://github.com/vanilla/vanilla/blob/Vanilla_2.2/.htaccess

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Thank you!

    The installation works with the 2.2 version's .htaccess file.

    Regarding the server, the OS is CentOS release 6.5, the default PHP version is 5.6, but multiple PHP versions including PHP 7 are supported. The server works with nginx as a reverse proxy and caching solution in front of Apache.

  • @Svetlio said:
    Thank you!

    The installation works with the 2.2 version's .htaccess file.

    Regarding the server, the OS is CentOS release 6.5, the default PHP version is 5.6, but multiple PHP versions including PHP 7 are supported. The server works with nginx as a reverse proxy and caching solution in front of Apache.

    so is the problem solved, and does your vanilla 2.3 forum work properly now with the older .htaccess

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Found this thread and also have problems with installation. Tried the old .htaccess for fun and now I can see the installation "panel". Mustn't that indicate there's something wrong in the download package then or?

Sign In or Register to comment.