Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

After uploading files I'm redirected to *.com/dashboard/setup - There is no file there.

I've chmoded all the files I'm suppose to, I've the file hosted on this site v2.3. I'm using PHP 7.0 and apache2

I've tried going to /vanilla nothing there.

https://gyazo.com/d2b9fc1619c7b19805effaf2579d3f25

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    *.com/dashboard/setup is equivalent to *.com/index.php?p=/dashboard/setup. What you see here is a rewritten url.
    Furthermore, you cannot find a file for each url you see. The index.php file is the start for every url. Generally you can read a url like that: yourdomain.com/controllername/methodname. You will be able to find a file called "class.controllernamecontroller.php" and that should contain a method methodname

    But said that, what exactly is your question? If you've tried installing the forum which is in a subfolder of your host and nothing happened, please edit the .htaccess file in your forums root folder. Search for # RewriteBase / and change it to # RewriteBase /vanilla (given that your subfolder is called "vanilla")


  • So, I set the fourm to /var/www/RiotFourm as a subdomain. After going to http://fourm.riotousstudios.com/index.php?p=/dashboard/setup I was greeted with a page however now once I fill out my details it redirects me to http://fourm.riotousstudios.com/dashboard/setup?

    I've tried changing the RewriteBase to RiotFourm, nothing changed.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please post the contents of your config.php file without the personal info like passwords and user names etc.

    This issue is either because you do not have pretty urls enabled or something else. Also post your htaccess file here.

    You never change RewriteBase to anything, that is a command .

    It should be RewriteBase / or RewriteBase /forum or whatever name , but you don't replace that command .. lmfao !!!

    Please read the documentation !!

  • edited January 2017

    Ether I've not explained my issue (that I've fixed) properly, or you're being obtuse.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Based on the links you posted you did not fix the issue. You need to enable rewrite url ...

    I am not going to beg you to provide more information. If you don't want to be helped or if you already solved this then say so in order to not waste people's time.

  • Ether I've not explained my issue (that I've fixed)

    (that I've fixed)

    ok

Sign In or Register to comment.