Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Vanilla 2.3 fully supports PHP 7. Get it now!

Link to setup cannot be found

This discussion was created from comments split from: Preview release: 2.4 beta.

Comments

  • I need someone help me. I can't access to install page.
    if you have installing manual will fine.

    thank you

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @super_rookie said:

    I need someone help me. I can't access to install page.
    if you have installing manual will fine.

    thank you

    Please check if there is already a file called

    Please try adding $Configuration['Garden']['RewriteUrls'] = false; to your config file.

    If there is a file called /conf/config.php, append the line above to that file. Otherwise add the line above to the /conf/config-defaults.php file.

    Reload your homepage and give feedback if you see a working forum then with working links.


    You need Apaches mod_rewrite. Even if it is enabled there are problems sometimes and you would need an older version of the .htaccess file, but more on that after you reported if the above config setting solved your problem

  • edited February 16

    I config this solution. It's successful !

    Thank you @R_J

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    It's a workaround, not a solution ;)

    I guess you would prefer to have "pretty" urls - urls without an "index.php?p=" in it. You need the Apache mod_rewrite module for that. If you do not have it, you will always see that "index.php". If you do have mod_rewrite enabled, follow the steps below to get pretty urls.

    Please set $Configuration['Garden']['RewriteUrls'] = true; in your /conf/config.php file (use config.php even if you made the initial change in the config-defaults.php!)

    Then edit the /.htaccess file and change the # RewriteBase / to RewriteBase /vanilla.

    Reload your forum in your browser and click on some links.

    Is everything working as expected? Yes? Great, you're welcome.
    If not, please proceed...

    Exchange the contents of your /.htaccess with this file: https://raw.githubusercontent.com/vanilla/vanilla/release/2.2/.htaccess

    Is everything working as expected? Yes? Great, you're welcome.
    If not, please proceed...

    Open your new /.htaccess file and change the # RewriteBase / to RewriteBase /vanilla.

    Now everything should be okay...

Sign In or Register to comment.