Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

When I enable it on V2.3 it throws error "rating is missing the following requirements Vanilla 2.3"

This discussion is related to the Rating addon.

When I enable it on V2.3 it throws error "rating is missing the following requirements Vanilla 2.3"

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    That is strange. Could you please look for the line 'RequiredApplications' => ['Vanilla >=' => '2.3'], in class.rating.plugin.php and replace it with 'RequiredApplications' => ['Vanilla ' => '2.3'],?

    x81kilo
  • @R_J i tried it but its not working. But when i completely removed the line and activated the plugin it did worked. and then again I added the same line into the plugin config file just to make sure it should not brake anything.

    After activation what i noticed is it sends all of my posts to next like have a look here: http://lonare.com/discussion/3/what-does-brexit-means-and-how-does-it-affect-us
    and logged in as admin I can increase as many rating as I want. Is that suppose to work like that? I was hoping one can only rate an answer only once based on his/her ip or account session details.

    let me know

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If 'RequiredApplications' => ['Vanilla ' => '2.3'],didn't work for you, are you sure you are working with Vanilla 2.3?

    But anyway: I have not tested downward compatibility and if the plugin works when you delete that line, simply do so.

    Yes, the admin is supposed to have unlimited votes. After all you are the god in your forum! "Normal" users only have the possibility to upvote or downvote. But they can change their voting any time

    x81kilo
  • guys, make it singular, not plural on RequiredApplication

    'RequiredApplication' => ['Vanilla ' => '2.3'],

    R_J
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sounds reasonable, but that is wrong. It only works that way because RequiredApplication is no valid key and therefore it is ignored.

    Try RequiredApplication' => ['Excel ' => '10.0']

  • Understood. and thanks for the clarification. I am a total n00b so I tend to tinker alot to try to get things to work. I figured it might have been a misspelling :-) anyhow, what else can be the issue, I know for sure I am on 2.3. Until a known fix is put out there, I will leave it set incorrectly as it allows the plugin to work.

Sign In or Register to comment.