HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

GDN_Permission How to fix the issue

Hello there, I'm Sidhkeer and I'm completely new to Vanilla.
So while installing it I got an error which says.

|Gdn_Database|Query|select * from GDN_Permission
Permission where RoleID = :RoleID and JunctionTable is null
order by RoleID asc limit 1

Please Help me out as soon as possible...



  • R_JR_J Ex-Fanboy Munich Moderator

    That shouldn't happen. Please re-upload all files to your server, clear the database and try again.

  • Still getting the same error :( ...
    More Information:
    Database Type: mySQL
    Database Limit: 1 GB Data and 150 tables.
    PHPv: 7.0

    And I tried both the method of uploading files:
    1) By extracting them in my PC and uploading then via Filezilla
    2) By uploading the zip directly (using 000webhost filemanager) to the root directory and then extract it to any sub directory (new one)


  • R_JR_J Ex-Fanboy Munich Moderator

    I don't have a clue what could be causing that. One more common problem has to do with the strict mode in MySQL beig enabled, but I would have guessed that this should be no problem any more. Please check that your database is not in strict mode - but if that doesn't help, I'm out of ideas...

  • This is still a problem while trying to upload in 000webhost !

  • R_JR_J Ex-Fanboy Munich Moderator

    If there is a problem with their file manager, you definitely should use a proper ftp client. It would be their deed to fix it and there is nothing Vanilla can do.

Sign In or Register to comment.