Please upgrade here. These earlier versions are no longer being updated and have security issues.

Advanced Editor - missing part of the toolbar...

whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
edited April 2017 in Vanilla 2.0 - 2.8

I've got an odd issue when I enable the Advanced Editor (well, I think it's odd...)

This is the editor as on here:

This is my enabled editor:

As you can see, it is missing the Attach file icon (which I don't really mind.)

However, in the Attach image section, it's missing part of the options (artfully boxed in blue below)

I can click and drag an image from my PC folder to the post, so the mechanics work, but the info/instructions and the Browse buttons are missing. This would seriously baffle many of my users, and means I can't use the editor.

On a local install, the File upload icon is still missing, but the Image upload section has the full options.

Anyone got any ideas what might be causing this?

As always, thanks for any help.

Tagged:

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    In the bundled editor that comes with vanilla, the file icon serves as file upload or image upload and thus the image icon is redundant.

    If you hover over the file icon, a tool tip should say Attach Image/ File There is no need to an extra or separate button to upload an image...

    When I click on the file upload icon I get the whole thing unlike here, where they are still using two separate buttons. Basically you got a better version of what we got here.

    If you use my custom tooltip plugin then your users will see the tooltip better and not be confused

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I think you could change the icon to represent a file, any file if that will solve your issue.

    Also based on your chosen format will be the icons under some cases

    /**
     * Hide some actions per editor view.
     *
     * Html, BBCode, and Markdown views have slight differences than the Wysiwyg,
     * so hide the particular ones.
     */
    
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @vrijvlinder

    Thanks for replying.

    I'm using the editor plugin bundled with 2.3 on my site when I get this issue.

    I don't have the file icon at all.

    I do have the image icon, but clicking it only displays the Image URL box, without the Drop image file option.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok, try this, disable and delete the editor plugin you have and try this one which I know works. If it still does not work, then some other plugin is affecting this.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @vrijvlinder

    Thanks for trying.

    On a clean local install the File icon appears as expected (with no image icon), but when I enable my theme the File icon goes and the image icon appears.

    I've no idea what could be causing it.

    I'll rebuild my theme bit by bit, and post on here if I find the culprit.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    It is almost always some kind of jQuery incompatibility . Does your Custom theme use jQuery?

  • I've just had this problem and there is a simple solution for it.
    This is a permissions problem, you just need to allow the corresponding group to upload images

    Go to Dashboard -> Users -> Roles & Permissions
    Choose the Group that should be able to upload and click Edit
    Tick Allow like in the Screenshot:

  • @whu606 did you find a solution for this?

  • Hello, I seem to have run into this problem as well.. image uploads worked at one time.. but I must have done something.. now I only get the URL section in the pull down??

  • or rather.. I should clarify that I used to get a dashed outline box around the WYSIWYG box when dragging an image over it.. now it is a red circle with a line. The only thing I can think of that I did between it working and now is the patch for 2.3.1.

  • Nevermind.. I had changed 'Categories' to custom permissions, and forgot to check 'Allow File Uploads'.

    R_J
  • donovanbdonovanb
    edited June 2017

    duplicate.. sorry.

Sign In or Register to comment.