Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Can't get to install yaga on vanilla 2.3

This discussion is related to the Yet Another Gamification Application addon.

Hello there, Am trying to get yaga 1.1 to work on my new community but after installing it, am unable to enable it. it gives the following error:
"The addon could not be enabled because it generated a fatal error:"

here is the error report it returns:

Undefined index: AllowDismiss

#0 /home/loopeuoi/public_html/talk.i.ng/applications/dashboard/views/modules/message.php(8): Gdn_ErrorHandler(8, 'Undefined index...', '/home/loopeuoi/...', 8, Array)
#1 /home/loopeuoi/public_html/talk.i.ng/library/core/class.module.php(130): include('/home/loopeuoi/...')
#2 /home/loopeuoi/public_html/talk.i.ng/library/core/class.module.php(263): Gdn_Module->fetchView()
#3 /home/loopeuoi/public_html/talk.i.ng/library/core/class.module.php(240): Gdn_Module->toString()
#4 /home/loopeuoi/public_html/talk.i.ng/library/core/class.modulecollection.php(45): Gdn_Module->render()
#5 /home/loopeuoi/public_html/talk.i.ng/library/core/class.controller.php(1364): Gdn_ModuleCollection->render()
#6 /home/loopeuoi/public_html/talk.i.ng/applications/dashboard/views/admin.master.php(37): Gdn_Controller->renderAsset('Content')
#7 /home/loopeuoi/public_html/talk.i.ng/library/core/class.controller.php(1853): include('/home/loopeuoi/...')
#8 /home/loopeuoi/public_html/talk.i.ng/library/core/class.controller.php(1314): Gdn_Controller->renderMaster()
#9 /home/loopeuoi/public_html/talk.i.ng/library/core/class.pluggable.php(199): Gdn_Controller->xRender()
#10 /home/loopeuoi/public_html/talk.i.ng/applications/dashboard/controllers/class.settingscontroller.php(108): Gdn_Pluggable->__call('render', Array)
#11 /home/loopeuoi/public_html/talk.i.ng/applications/dashboard/controllers/class.settingscontroller.php(108): SettingsController->render()
#12 [internal function]: SettingsController->applications('', '', '')
#13 /home/loopeuoi/public_html/talk.i.ng/library/core/class.dispatcher.php(326): call_user_func_array(Array, Array)
#14 /home/loopeuoi/public_html/talk.i.ng/index.php(44): Gdn_Dispatcher->dispatch()
#15 {main}

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Where did you install it ? It should be in the applications folder not the plugins folder.

  • @vrijvlinder said:
    Where did you install it ? It should be in the applications folder not the plugins folder.

    I installed in the applications folder. It shows on my dashboard but i cant enable it because it returns the above error.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Do you have pretty urls enabled ? Is this clean install of Yaga ?

  • @vrijvlinder said:
    Do you have pretty urls enabled ? Is this clean install of Yaga ?

    i pretty dont know how to check if pretty url is enable but from what i've checked it seems to be enabled because my urls dont have the "index?p=" .

    As for the clean install, this is the first time am attempting to install yaga.

  • Please I seriously need help on this. I've tried all I could.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The above error message is not helpful. It is only a notice (not an error) which doesn't even is connected to YAGA but to the messages that you can write from the dashboard (not conversation messages).

    If you are really desperate, please make a backup of your database and do the following:
    1. add $Configuration['EnabledApplications']['Yaga'] = 'yaga'; to your /conf/config.php
    2. run /utility/structure after manually enabling YAGA

    This will most probably not solve your problem, but I would expect it to give more helpful error messages.

    While you are testing this it might happen at any time that your forum isn't accessible any more, so don't do this on a live system. After testing, please remove the above line from the config.php

    If possible you can also try to disable it from the dashboard. Even then there might be errors but they could give helpful information

    chidez
  • @R_J said:
    The above error message is not helpful. It is only a notice (not an error) which doesn't even is connected to YAGA but to the messages that you can write from the dashboard (not conversation messages).

    If you are really desperate, please make a backup of your database and do the following:
    1. add $Configuration['EnabledApplications']['Yaga'] = 'yaga'; to your /conf/config.php
    2. run /utility/structure after manually enabling YAGA

    This will most probably not solve your problem, but I would expect it to give more helpful error messages.

    While you are testing this it might happen at any time that your forum isn't accessible any more, so don't do this on a live system. After testing, please remove the above line from the config.php

    If possible you can also try to disable it from the dashboard. Even then there might be errors but they could give helpful information

    I've actually fixed this by doing a clean install of vanilla forums. The problem I think stemmed from the mode of installation. I installed the forum software using softaculous. I guess thats where the problem came from.

    Thanks for your time and help
    @R_J
    @vrijvlinder

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I keep saying to people not to use one click installers...

  • Seriously, like they don't install properly most times.

    vrijvlinder
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Glad you sorted it out and went away from that installer. They really have no benefit.

Sign In or Register to comment.