Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

HTTP 500 ERROR after upgrade from 2.21 to 2.3

pdqlinuxpdqlinux New
edited May 2017 in Vanilla 2.0 - 2.3

I've made 3 previous release updates without issues but ran into one now. I've uploaded the 2.3 files overwriting existing vanilla files.folders, deleted .ini files in /cache and now the url just http 500 errors on homne page and utility update page. Also tried removingextra plugin and application lines from config.php Help please?

[error] 1963#0: *2383 FastCGI sent in stderr: "PHP message: PHP Fatal error: require_once(): Failed opening required '/srv/beta/vanilla/vendor/autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /srv/beta/vanilla/bootstrap.php on line 50" while reading response header from upstream, client: 123.456.789, server:, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: ""

The path and file exists: /srv/beta/vanilla/vendor/autoload.php

PHP 5.5.9-1ubuntu4.21


  • Sorry, I posted this discussion in the wrong Category. I reposted it in the correct Category now.

  • K17K17 Unlosk · Français / French ✭✭✭
    edited May 2017

    Check if you have Rewrite Rule enabled on your server.
    Wich update ? 2.3 or 2.3.1 ? If 2.3, try 2.3.1, and if 2.3.1, try re-send all files trhought FTP.
    I hope you had did backups before trying to update, as recommanded into the standard update instructions.

This discussion has been closed.