Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Advanced Editor - Cannot upload images

when clicking on the icon to upload an image I only get the url option not the drag and drop hence not letting me upload anything.

Has anyone seen a similar problem?

vrijvlinder

Answers

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You don't need to click anything to drag and drop, just drag the file into the editor box. The button is just for adding a url ...

  • @vrijvlinder well this is what I get, and if I drag and drop the image just opens in the browser.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    please make me a temp admin account and send me the login info in private message so i can take a look.

  • I've got this same issue. Any pointers?

  • Nevermind.. noob mistake.. I had changed 'category' permissions to custom.. and forgot to check the allow file uploads!

  • Hello. I have an issue regarding uploading images... I mean i can upload images, as an admin...but other users cant. The problem is when i try to give users permission to upload images.. I go to categories - check the box "this category has custom permissions" and the check "allow file uploads"...then i save, but when i reenter the option, the "allow file uploads" it's unchecked...it doesn't save the option. Do you have any ideea what might be the problem?

  • K17K17 UnkornegLosk · Français / French Nouvelle Aquitaine / La Rochelle ✭✭✭
    edited September 9

    Have you tried by change permissions in Roles & Permissions ?
    Edit the "Member" role and click "Allow" in files upload
    Make us a feedback.

  • Well...i don't see the option "files upload" in the "roles & permissions" tab. i attached a printscreen of this:

  • @Octaviann said:
    Hello. I have an issue regarding uploading images... I mean i can upload images, as an admin...but other users cant. The problem is when i try to give users permission to upload images.. I go to categories - check the box "this category has custom permissions" and the check "allow file uploads"...then i save, but when i reenter the option, the "allow file uploads" it's unchecked...it doesn't save the option. Do you have any ideea what might be the problem?

    Do you have shell access to your server? Can you see the permissions set on your config directory? (ls -la conf)

  • I checked the config file from conf directory.
    $Configuration['Garden']['AllowFileUploads'] = true;
    $Configuration['EnabledPlugins']['FileUpload'] = true; (this one was first on false...but i checked again if uploads are working for members after i put it on "true" but it didn't worked...)
    What could be the problem?

  • @Octaviann said:
    I checked the config file from conf directory.
    $Configuration['Garden']['AllowFileUploads'] = true;
    $Configuration['EnabledPlugins']['FileUpload'] = true; (this one was first on false...but i checked again if uploads are working for members after i put it on "true" but it didn't worked...)
    What could be the problem?

    Anyone, please? I really need this to work on my website. My forum address is: https://videochatforums.ro

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @Octaviann said:
    Well...i don't see the option "files upload" in the "roles & permissions" tab. i attached a printscreen of this:

    I guess your problem lies in the theme. The dashboard has been styled and the way it has been styled might be the reason for your troubles. Please enable the default theme and try to change the setting in the category again.

  • Hello again. I tested my current theme, to see if this is the problem. I activated the default theme (baseline) and still, the "allow file uploads" option under category custom permission doesn't stay checked after i save it. So it's not from my theme. But what else could it be? Any ideas?
    I'm lost at sea here guys... and i really need this option enabled. I have members quit posting pictures in my forum because it's too complicated (...) for them to upload pics via the url option..or don't know how to use it.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sounds like you have severe problems but you can try if changing the information in the database is of any help.

    If you have a tool like phpMyAdmin at hand, look at the GDN_Category table and change the "AllowFileUploads" column to "1" for the desired category.

Sign In or Register to comment.