Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

SSO timed out during the request

This discussion is related to the Vanilla jsConnect addon.

Hello all,

I successfully implemented jsConnect (version 1.5.3 on Vanilla 2.3) with my existing none SSL enabled site, everything worked fine between the forum and the SSO endpoint. However, when I enabled SSL on the server, I'm returned a loading page with the "Your sso timed out during the request. Please try again." message.

A few things:

  1. SSL works fine when traversing the forum and posting and I can use the /entry/password method of logging in.
  2. Via the jsconnect settings, I have changed the authentication URL, Sign in/out URL, and registration URL, to point to the https site.
  3. When running the test connection in the jsConnect Settings, I receive back the appropriate json information for the test.

I've gone back over the the technical documentation and searched the forums, but can't figure out why its not working.

I assume its something to do with the SSL configuration, but everything else seems to work fine with the test in jsConnect Settings.

Any insight and help you can provide, is greatly appreciated.

Thanks!

Comments

Sign In or Register to comment.