Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Update from 2.1.10 to 2.3

Hi , I m using the version as mentioned in the title and want to update to latest release on my live site, can you suggest the safest way to do that or if anyone has faced any issue updating that and how to rescue?
Thanks

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Make a backup of
    a) your database
    b) the files in the /conf folder and the /uploads folder
    c) the .htaccess

    and start trying!

    There might be some plugins which can cause problems. You should check that first by looking here in the addons section under each plugin that you are using.
    The .htaccess file of the new version seems to cause troubles for some people, so if you face errors you should try using the backed up version.

    Before you start, you should surely read info about the update procedure, but there is nothing complicated in there.

    If you really need to, you can always come back to the old version by copying the version 2.1 installation files and your backup to your installation. But it would be much better to solve any problems that may arise.

    Keep on asking if you face problems!

  • Hi, @R_J,

    Thanks for your reply, well I m totally new to this, and have already tried your suggestions but still no help, the forum just stops loading now.

  • I have followed these steps and I am not having any luck.

    I made a backup of my site files and my database. Then I upload the new version and overwrite old site files. At that point the /forum on my site returns nothing but 404.

    I did replace the .htaccess with the backed up copy, but that doesn't help. I don't have any plugins running. It's a very clean Vanilla 2.1.10. If I restore my backed up site files and database it works just fine again, and it's already using URL rewriting in 2.1.10 without any problems. As soon as I try to update again everything breaks.

    Not sure what else to try at this point..??

Sign In or Register to comment.