Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

How can I fix this 2.3 update?

edited June 16 in Vanilla 2.3 Help

I see a lot of this, but nothing seems to be helping. I have a server configured with Apache + nginx running together. I have many WordPress sites and Vanilla 2.1.10 running just fine with pretty URLs via htaccess rewriting.

I'm trying to updated to Vanilla 2.3, but when I upload all the new files I end up with 404s. The README mentions that "Additional setup is required on nginx and other platforms" but it doesn't go into detail.

In the forum and other places, I see people talking about how to fix this, and this link seems to provide the most simple method, which is basically to add this to the nginx vhost:

 location /forum
 {
 try_files $uri $uri/ @forum;
 }
 location @forum
 {
 rewrite ^/forum(.+)$ /forum/index.php?p=$1 la@ForumBagusCom 

We've tried this and some other more lengthy methods and nothing seems to be working for us. Our Vanilla install is indeed located at /forum.

Any information on how I can get this fixed would be greatly appreciated. Thanks!

Answers

  • edited June 16

    Nothing for me on this..?? I'd love to grow with this solution and continue referring it to others, but if a simple update is this problematic even after following the instructions that are available and the support forums provide zero response it's a little bit difficult to do that.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 17

    Basically the htaccess file for 2.3 is screwed up and if you did not save your old one it got overwritten..it is a hidden file for some reason and you can't see it in your file system on your computer after you extract the downloaded new vanilla version. You need to enable viewing of hidden files on your computer, in order to avoid this problem. That is why it is useful to read the tutorials about updating.

    There are at least 100 new discussions here with the same problem and the same solution.

    @angelleye_ said:
    Nothing for me on this..?? I'd love to grow with this solution and continue referring it to others, but if a simple update is this problematic even after following the instructions that are available and the support forums provide zero response it's a little bit difficult to do that.

    This support forum is made up of users who are volunteers and have a life other than to be here for you when you need help with trivial issues that have been resolved by simply searching the forum or reading the Tutorials available.

    This is a self help forum. You help yourself to the info that has been accumulated to solve your problem.

    Please read the tutorial section. The process of updating is the same and the steps you need to take are the same regardless of the version the tutorial was written for. Once this information becomes obsolete, it will be removed. For now it stands and you must make an effort to read it or search the forum for about 404 error.

  • Thanks for the response.

    I did make a backup of everything prior to updating, and I did try using the original htaccess file, but it still doesn't work. I compared the two and tried to merge them with a fresh one, but that isn't working either.

    I'm very familiar with working with hidden files. It's visible, and again, I've tried the original as well as a fresh one created manually (copy/paste what was included with Vanilla) and nothing is working.

    I did search the forums, and I tried numerous "solutions" that did not work regarding updating the vhosts configuration in Nginx.

    I did read the tutorials, and I read the README, which as I mentioned in the original post simply says "Additional setup is required on nginx and other platforms." It does not go into detail or reference any additional material on that, though.

    So again, I did plenty of searching in the forums and found about 20 different variations of how people are saying they got theirs working with some very lengthy configuration adjustments to the vhost in nginx, and other more elegant versions, but none of them are working when I apply them (and many of them are seemingly out-dated.)

    So yes, of course I have made an effort. I don't post in forums until my own efforts have come up with empty results, and when I do follow tutorials and README files exactly, and it simply doesn't work, I have no where else to turn.

    So again, if I DO have my original htaccess and it doesn't work, and I DO have hidden files displaying and being used correctly, and I DID follow the upgrade instructions and information available in other threads but nothing fixes it...what is the next step to troubleshoot?

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 17

    Can you please post your htaccess file code here? Or better yet try this free online converter for server rules, just copy the contents of the htaccess file and it should convert it to the config format for nginx.

    https://winginx.com/en/htaccess

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    My nginx setup doesn't need anything else than:

        location / {
            try_files $uri $uri/ @vanilla;
        }
    
        location @vanilla {
            rewrite ^/(.+)$ /index.php?p=$1 last;
        }
    

    I'm not quite sure how "Apache + nginx together" really works and if you still need a .htaccess file at all.

    1. Have you deleted all *.ini files from /cache after the update?
    2. Don't remember if it have been 2.3.1 or 2.4, but some of the recent updates required that you delete old files, otherwise you would face 404s in the backend. Could that be the problem?
  • edited June 21

    Thanks for the responses!

    I've tried all of the recommendations, and I had my server admin focused on this for 2 full days and couldn't get it working. I gave up, removed nginx from the equation, and now the forum is loading again.

    vrijvlinder
Sign In or Register to comment.