Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Can only view dashboard after install

Hey!
I just installed Vanilla 2.2 and I'm hosting it using the latest XAMPP currently. (v3.2.2)
After installation I'm redirected to the dashboard which is normal. But then when I click "Visit Site" I get brought to a blank screen.
Vanilla is not in the root directory. localhost/forum is where Vanilla has been installed on my computer.

# Original
# If you modify this file then change the above line to: # Modified
<IfModule mod_rewrite.c>
   RewriteEngine On
   # Certain hosts may require the following line.
   # If vanilla is in a subfolder then you need to specify it after the /.
   # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
   RewriteBase /forum
   RewriteCond %{REQUEST_FILENAME} !-d
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
</IfModule>

That is my .htaccess

How can I resolve this? Any help would be appreciated!

Comments

  • @vrijvlinder said:
    You need version 2.3.1

    Is there a way to use Vanilla 2.2 instead?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Why would you want to use a lesser version with serious security flaws ?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Version 2.2 has security issues and if you use it, you are acting irresponsible against your users and your hoster. Don't do that.

    Is there a way to use 2.2? Surely, yes. But if you have to ask, you shouldn't do that. You would have to start by tracking the changes between version 2.2 and 2.3.1. Find out which changes have to be made due to security issues. That changes must been made. There might be other changes or features added. If you do not want them, you do not have to.

    What you have afterwards is a forum based on Vanilla, not really Vanilla anymore. As a result, whenever there is an improvement based on any code changes, you can take no benefit from that. Furthermore it would need a real good understanding why something has changed.

    On the long run you will miss improvements that are introduced in new versions and you would update anyway. So I would say there is no sense in not using Vanilla 2.3.1 from the start.

    But it's all up to you...

    What you seeing is a blank screen and that is not an error. You would have to find out what the error might be. Search this forum for "blank screen". There should be some discussions that help with that problem.

    DaPerson
Sign In or Register to comment.