Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Internal Server Error on Fresh install

I'm installing Vanilla 2.3.1 for the first time. I downloaded the package from here and uploaded to my server ( i visited the link and got a 500 error.

I've tried adding $Configuration['Debug'] = TRUE; to conf/config-default.php and I've enabled RewriteBase / in the htaccess file. I've also tried RewriteBase /forums/ but none of the solutions have worked. Any ideas?


  • Options
    R_JR_J Ex-Fanboy Munich Admin

    I would make it RewriteBase /forums without the trailing slash, but I don't think that's the problem.

    If you get an internal server error, you should check the apache log files. You might have to check back with your hoster if you don't know how to access them.

  • Options

    They seem to be permission issues. I got this error

    SoftException in Application.cpp:264: File "/home/vipul/public_html/forums/index.php" is writeable by others

    My folder permissions in forums/ are 777 and file permissions are 666. My host says they are too high to be safe so apache stops it. Can vanilla function properly with lower permissions?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    There is a tutorial that covers this exactly, did you read it?

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    You should never give 777 permissions, you just made your index page writable by anyone.. no bigger than 775 is ever necessary. I am surprised your host did not prevent you from doing that...

    You did not follow all the steps. Try deleting the .ini files from the cache anytime you modify something...

  • Options
    VipulKVipulK New
    edited June 2017

    I got it working. Thanks guys. The folder permissions are 755 and file permissions are 644

    @vrijvlinder I just downloaded the zip file and uploaded it to my server and extracted it in the folder. It had those permissions by default. I didn't change them because i thought they were necessary for installation. It must have to modify files after all.

    I checked the documentation and in the Installation section, all it says is view the README for instructions. And that didn't say anything about permission issues. This was also not mentioned in the troubleshooting section.

    I haven't read the tutorial about permissions that you are talking about. I didn't come across it in my search.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    There is a very good description which hasn't been in the tutorial category, since that category didn't exist at the time of writing.

    I just moved it there

Sign In or Register to comment.