Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Having login problems

unipusunipus New
edited September 2006 in Vanilla 1.0 Help
I'm migrating a forum over from YaBB currently, and the basics have been going pretty well... however now I am having strange login problems. The root of the problem was this, I think: When I imported my users, I ended up with two users who existed with the same name. When I logged in, I would end up as the second user, not the one with admin priviledges. So I went into the DB and deleted the non-admin clone. But now it's telling me "The requested user could not be found". I've further gone into the database and changed the user name to simply 'admin', thinking that possibly spaces might be an issue, but still no go. And the same thing happens when I try to log in to ANY of the other users I have passwords for. I'm looking at the tables and everything looks fine.

Comments

  • Options
    Well, looks like it was some weird caching problem in my browser (Firefox 1.5.0.6 / OS 10.4.7), because "The requested user could not be found" was coming up with EVERY request, even blank ones. I opened up a Safari window and tried it and bam, it worked. So that problem seems to be solved(?) for now... might be another interesting bug, though.
  • Options
    MarkMark Vanilla Staff
    You were still signed in as the other user, I bet.
  • Options
    The one I deleted? Possible. But I did also hit the log out button after that.
  • Options
    I experimented a problem at login (bug?). I already instal Vanilla in a Debian Server. When I try to login in Vanilla, I was redirect to the front page instead of the member page (this happen whit a member or administrator account), like a unregister. I test putting a bad password and this works well (don't redirect and appear the warning advice). For this reasson I can't enter on my accounts. The only form to enter in the accounts page is when there are a new member to accept. I use many browser and is the same. Server System: Debian 3.1 r2 / php5.1.2 / cherokee 0.5.4 User System: Os X 10.4.7 / Firefox, Camino, Opera, Safari
  • Options
    Check your error.log.
    It might be problem with the session path.
  • Options
    The only file error.log that I have is in /var/log/apache2/error.log but I don't use it (I have installed Cherokee Web Server 0.5.4). Today I install other server (similar configuration), and install Vanilla 1.0.1 with the same problem (its redirect to the index.php without login me). PS (Where I check the path?) Server System: Debian 3.1 r2 / Php5.1.2 / Cherokee 0.5.4 / Mysql 5.0.22 User System: Os X 10.4.7 / Firefox, Camino, Opera, Safari
  • Options
    Check into php.ini where does php write is messages. For the seesion path it is in the same php.ini, and it must be "session.path ="
This discussion has been closed.