Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

A fix for 'The requested URL /dashboard/setup was not found on this server.'

After looking through all of the forum posts on this issue and never finding a solution..

yes, the htaccess file was present.
no, changing the .htaccess file to / instead of /vanilla default did not help
the rewrite url flag in the config file didn't exist.. nonetheless, config.php also didn't exist, so users were being told to edit the wrong file.

What was my problem? the default virtualhost settings in apache2 under ubuntu 16.04, that's what.


# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

What i added was this line, right below document root:

AllowOverride All

This allows .htaccess files to even be read.

Vanilla should have some dummy warning message about this. This has tripped up so many people, including me.

vrijvlinder

Comments

Sign In or Register to comment.