Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Advanced Editor Upload Picture and "Debug=true" problem

Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
edited September 6 in Vanilla 2.3 Help

Hi again.. ;)

After moving my Forum to another Server, thought everything is fine... :lol:
BUT..
My Users pointed out, that there are unable to upload Pics.. :confused:
Aaaand there right!! Can*t upload Pictures over the advanced Editor...

I'm getting an "the file failed to upload" error..

Brovser console saying "....CaBaFoRuM/index.php?p=/post/editorupload 500 (Internal Server Error)"

Checked File and Folder permissions, seems OK...
did the R_J Script and the Linc Database permissions

Still not working.. :cry:

Strangely other Files, as .txt., .mp3. .zip are working! Maybe it has something to do with the insertion of the pic into the editor?? :confused:

I also tried the $Configuration['Debug'] = true; Option in the config.php file... but when I then go into any discussion, I get this error:

Searched all day for a solution, but nothing is working... :cry:

here are some additional informations:
Application: Vanilla
Application Version: 2.3.1
PHP Version: 7.0.22-1~dotdeb+8.1
Operating System: Linux
Server Software: Apache/2.4.25 (Debian)

Appreciate any Help, thx... :heart:

Comments

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Nobody has an idea? :surprised:
    Really stuck here... :cry:

  • Could you try to upload an image and then take a screenshot of the ending of your error.log file?

    https://askubuntu.com/questions/14763/where-are-the-apache-and-php-log-files

    Dr_Sommer
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If you get a fatal error in every discussion when debug is true, you have a serious problem.

    The error message is quite informative: writeDiscussionOptions is deprecated. That means that one of your plugins uses a Vanilla function which isn't supported any more.

    You can do one of two things to find out which plugin causes that:
    1. disable all plugins and re-enable one after the other, testing if the discussions show as expected after each step
    2. do a full text search with a good editor or a grep search through the plugin folder for writeDiscussionOptions (case insensitive)

    I guess updating that plugin would solve your problem.

    Dr_Sommer
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited September 8

    @Caylus :
    There seems to be no forum related errors in the log file... but that can`t be right.. . :blush:
    I look into it and will give feedback.. :+1:

    @R_j :
    Sorry, didn't mention that I did deactivate all plugins.. as learned from earlier errors... :lol:

    so I used your second proposal.. searched my backup Forum on my PC with "Astrogrep" ... and indeed.... it`t the BOOTSTRAP THEME!! :surprised: (NOT the Bootstrap Theme!! :scream: see discussion below! )

    Ou maaan.... always disable all Plugins AND change to the STANDARD THEME when having problems!! :angry: :lol:
    I`ll never learn (hitting several times my tooshie )... :lol:

    Ok, I`ll write a note in the plugin/theme diskussion of "Bootstrap" .... :+1:

    BUT:

    The picture upload problem remains...

    After uploading a Image with the "Baseline+" Theme, it still says "The File failed to upload" and no error messages in Debugmode!!! :confused:

    I`ll now try to get the error.log working, hopefully there are more informations... :+1:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The clean, unaltered bootstrap theme doesn't use this function. I guess you have some custom changes in there...

    Dr_Sommer
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited September 8

    Haha... noooooo..... I was slightly happy that it wasn`t my fault... BUT IT WAAASS!!! :angry: :lol:
    I downloaded the original bootstrap theme and compared... :surprised:

    After so many flawlessly working forum years, I forgot what I had changed... :blush: :lol:

    I put an views/discussion/index.php into the theme to alter the discussion views... :blush:
    If I remember right, I copied this from /applications/vanilla/views/discussion/index.php and altered it...

    and this was certainly an old Forum version... :blush:

    ok, ok... learning mode is ON... :lol: Error NO 1 has been corrected... :+1: step by step to a hopefully working forum again... :lol:

    ThX, R_J .. :heart:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Tell us what you have changed/what you tried to achieve and let's see if we cannot solve that problem more elegant

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    thanks a lot, R_J.. :heart:

    Let me first just find that upload error, then I`ll post my modifications to the Discussion View... :+1:

    My users get impatient, if they can`t upload some never before seen CAT pictures... hehehe... :lol: :lol:

    Caylus
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sure, you're right.

    But like Caylus already said, you have to find the error logs...

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited September 8

    Interim report: :winky:

    Found /var/log/apache2/errorappache.log (changed it into "errorappache.log" to be shure its the Apache2 error log

    content:

    [Fri Sep 08 14:27:46.658390 2017] [mpm_prefork:notice] [pid 4376] AH00163: Apache/2.4.25 (Debian) configured -- resuming normal operations
    [Fri Sep 08 14:27:46.658431 2017] [core:notice] [pid 4376] AH00094: Command line: '/usr/sbin/apache2'
    [Fri Sep 08 14:27:51.633180 2017] [mpm_prefork:notice] [pid 4376] AH00169: caught SIGTERM, shutting down
    [Fri Sep 08 14:27:51.725040 2017] [mpm_prefork:notice] [pid 4421] AH00163: Apache/2.4.25 (Debian) configured -- resuming normal operations
    [Fri Sep 08 14:27:51.725066 2017] [core:notice] [pid 4421] AH00094: Command line: '/usr/sbin/apache2'
    [Fri Sep 08 14:28:48.516293 2017] [:error] [pid 4447] [client 91.196.50.33:49726] script '/var/www/html/testproxy.php' not found or unable to stat
    [Fri Sep 08 14:46:20.447520 2017] [mpm_prefork:notice] [pid 4421] AH00169: caught SIGTERM, shutting down
    [Fri Sep 08 14:46:20.552323 2017] [mpm_prefork:notice] [pid 4547] AH00163: Apache/2.4.25 (Debian) configured -- resuming normal operations
    [Fri Sep 08 14:46:20.552350 2017] [core:notice] [pid 4547] AH00094: Command line: '/usr/sbin/apache2'
    

    Also found:
    /var/customers/logs/caba-error.log (using froxlor)

    Content full of errors concerning my selfmade "plugins".. so I have to resolve these errors first... :scream:

    Also found:

    Browser Console:

    jquery.min.js?v=2.3.1:6 POST http://caba.de/CaBaFoRuM/index.php?p=/post/editorupload 500 (Internal Server Error)

    After searching for "editorupload" with Astrogrep, found:

    \plugins\editor\js\editor.js
    \plugins\editor\class.editor.plugin.php
    

    As suspected, it has to do with the preview image insertion, cause other files like TXT, MP3, ZIP have no preview inside the Editor and are working... :dizzy:

    So I`ll first kill my errors, then check the log again and tell you about it... :+1:

    p.s.: I think these errors (my plugins) are coming from porting everything from php5 to php7....

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited September 8

    ok, okeee.... I found this:

    AdvancedEditor not writing Images to GDN_Media

    Checked my DB, the mp3, txt, zip, etc. files are in the DB, but images that I tried to upload, not!

    So just FYI... :+1:

    how can I check if the DB Permissions of the "GDN_Media" Table is ok?? :confused:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    :idea:

    Do you have the PHP GD extension installed?

    Dr_Sommer
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Waaaaa!?!?!?!? So HOW in GOTTES NAMEN did you know that!?? :awesome:
    YESSS!!! It was the GD extension... :dizzy: :bawling:

    You are a Fu....ntastic GENIOUS!!! :awesome: :heart:
    I would NEVER come to this conclusion.... :surprised:

    I`ll not bother you with details, how I could not install it, hat to reinstall PHP7 and lost two hours of lifetime.... :lol:

    But your magic did the trick... :+1:

    I`m so relived... thx, Bro... :lol:

    If you ever come to Frankfurt, dont hesitate to contact me and well go out for at least 6 Beers!! :lol:
    (und das ist keine Floskel, das meine ich wirklich so!!! : )

    Thanx... as always, you`re my big savior... :heart:

    So where did I go wrong? How is this extension installed? By Vanilla forum installer?? Or how?
    By installing php7.0 and php7-common its not installed... I had to install it additionally...

    I like to learn from my mistakes... :lol: :+1:

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    FFM? Selten, aber falls es sich mal ergibt komm ich darauf zurück =)

    Dr_Sommer
Sign In or Register to comment.