Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Trouble enabling Chatwee

This discussion is related to the Chatwee addon.

The Chatwee download I've installed does not contain documentation. There is nothing in comments either within the PHP. There is a GNU license doc, and that's it. I've got the plugin saved in the plugins directory, and I can see the Chatwee icon in the Manage Plugins page as well as in the Addons sidebar list. But the Settings button and the link under Addons does nothing but give me:

View not found. The view you were looking for could not be found.

Can anyone post what the readme file says, if there is one?
Thanks.

Comments

  • Figured it out. The views directory didn't have permissions. Used chmod 777 and it's working. But if someone could still post documentation, that would be awesome. Thanks.

  • @chatwee @mtrgrrl, there's an error in the Chatwee plugin.

    Line 79 of class.chatwee.plugin.php checks for a permission Vanilla.Settings.Manage, which doesn't exist.

    Instead it should check for Garden.Settings.Manage. Now only "super" admins (being simply an administrator is not enough) can change the settings since the permission system doesn't apply to superadmins anyway.

    If you change Vanilla.Settings.Manage to Garden.Settings.Manage it should work.

    mtrgrrl
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    If you post a thread from the relevant plugin page

    https://open.vanillaforums.com/addon/chatwee-plugin

    in this case, you have more chance of the author noticing the issue.

    Just click Ask a question from the plugin page.

  • @Caylus I didn't have any problem enabling the plugin after changing permissions (changed it to 555 later). I tried your edit to see if that would help, but I still needed to chmod the views directory.

  • @Caylus Well, that was my Sandbox where I didn't have any problems enabling the plugin. But on the actual VM, I did have a problem, and your fix worked. Thank you!

    Caylus
  • Glad it worked out! Just in case anyone else runs into this problem, a more extensive explanation:

    It's not the file system permissions that are the problem (which could be solved by 555), it's the Vanilla Forum permission system.

    @chatwee 's code told Vanilla that only users with Vanilla.Settings.Manage permissions were allowed to view the settings page. Since that permission doesn't exist, no one was allowed to view the settings page.

    Except superadmins (=people who have the Admin column set to 1 in gdn_users), since permission checks don't apply to them, period. That's why in your sandbox you could access the settings page (since you're apparently a superadmin there), but on the VM you couldn't (since you're 'merely' an administrator).

    Now you changed it to Garden.Settings.Manage, that permission does exist (the moderator role and administrator role both have it), you don't need to be a superadmin anymore. Which is a good thing, since I don't think there's any way to become a superadmin except edit the database :P

    R_Jmtrgrrl
Sign In or Register to comment.