Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Column 'CountComments' cannot be null error in Vanilla Porter

edited September 2017 in Vanilla 2.0 - 2.8

Hi all,

On 2.3.1 and I'm trying to import my current installation over to a new webhost (I'm on 2.3.1 for both installations).

Export worked fine, and the import starts and these complete OK:

Process Import File
Define Tables
Load User Table
Authenticate Admin User
Insert User Table
Load Tables
Delete Overwrite Tables
Insert Tables

but then I get "Column 'CountComments' cannot be null" error

And then the below "Update Counts" just sits there at 1 of 3.

Update Counts
1 of 3
Custom Finalization
Add Activity
Verify Import

Anything I can debug to figure this out?



  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    Porter isn't intended for use with Vanilla - Vanilla updates.

    To move your DB from one host to another, you should use phpMyAdmin (or similar) to export and import the DB.

  • Options
    edited September 2017

    Hi thanks for the response, @whu606.

    It's not a Vanilla-Vanilla update or upgrade. I'm simply moving hosts, and Vanilla Porter supports Vanilla 2 as one of the options for exporting.

  • Options

    Hey Lament,

    Whu606's stays valid: I'd try exporting and importing your database via your webhost and not bother with the porter:

  • Options
    edited September 2017

    Hi guys,

    Thanks for taking the time to help, btw.

    So here's where I'm at so far.

    removed all files on the new host and installed base vanilla
    removed the mysql db on the new host and created a new one
    installed base vanilla.

    All good. Working great.

    Then I tried to import the sql file into the new db via the command line, and I'm getting:

    ERROR 1054 (42S22) at line 48: Unknown column 'CommentActivityID' in 'field list'

    Would turning off any plugins help? I tried importing before I added the couple of plugins that I'm using (Time Ago, OnlineNow, PostCount and Analytics), and after.

    Also I noticed when I ran /utility/structure/all, it says I need to make some changes.. but I haven't done anything yet.

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Don't try to import the old dB into a new Vanilla dB.

    Import it as a separate, standalone dB, then point your conf.php file to that DB. Clear the ini files from the cache folder, and maybe run utility/update.

  • Options
    edited September 2017


    Good call. Imported into new db. But now I'm getting the following:

    Fatal Error in PHP.trigger_error();

    Unknown column 'w.Participated' in 'field list'
    The error occurred on or near: /var/www/html/library/database/class.database.php
    422: if (!$message) {
    423: $message = $ex->getMessage();
    424: }
    426: trigger_error($message, E_USER_ERROR);
    427: }
    429: }

    Running the utility failed. Let me try the /utility/structure/all.

  • Options
    edited September 2017

    Doing the/utility/update worked this time.

    We're getting somewhere. I see the forum. Looks good..

    Edit: OK all good. @whu606 and @Caylus thanks so much!

Sign In or Register to comment.