Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

does vanilla have any cache?

mikerdsmikerds New
edited October 2017 in Vanilla 2.3 Help

Hi there!
I am absolutely lost O.o here is what happened.. I created my own theme and didn't touch it for a few weeks. Yesterday, I wanted to change something in the template. But when I change default.master.tpl in my theme, the changes are not visible. It looks like it picks up an old template from cache or from somewhere...

I tried everything.. 1) switching to a new theme and back 2) opening a forum from a different browser 3) cleaning browser cache 4) removing ini files from cache folder on the server.

Nothing helps, it still shows the old template.

could it be some side effect of some plugins?

Please help :-)

Thank you
Mike

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes it does, but it may be your host too. There are settings on your host to refresh after a while. But I recommend you try a css re-loader browser extension to reload the fresh css sheet.

    Best thing is the plugin CSSEDIT where you put your changes and will show right away because plugins CSS sheets supersede the theme.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    I once had a similar issue because I had thought to keep a backup copy of the default.master file in the views folder. Just in case you've done the same.

    mikerdsLinc
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Vanilla uses Smarty for the default.master.tpl. Normally you should have to do anything, but if Smarty doesn't recognize that the file has been changed, you have to delete the compiled template(s) manually. Delete all *.php files from /cache/Smarty/compile.

  • @whu606 said:
    I once had a similar issue because I had thought to keep a backup copy of the default.master file in the views folder. Just in case you've done the same.

    Yes! This is what happened to me! I saved bak file for default.master in the same folder. Thank you for solving my problem!

Sign In or Register to comment.