Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1

Recently upgraded to 2.3.1 but new users can't register

When new forum users try to register or sign up they get the error page. Should I clear the cache? Nervous about losing information if I do this.

Best Answer

Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited October 31

    @cckaadmin

    The crucial bits of your forum, users, threads, posts, etc., are held in the DB, which is separate to the Vanilla files/folders.

    Clearing ini files from cache should have no negative consequences. Deleting the Smarty folder will cause issues that won't be resolved until you create it again.

    When you say 'the error page' could you clarify?

    Do you mean 'Something has gone wrong'?

    If so, you will need to set

    $Configuration['Debug'] = true;

    in conf/config.php (add the line if it isn't already present, otherwise set 'false' to 'true'.)

    Then log out, try to register, and see what the actual error is.

  • Yes, they are getting the Something has gone wrong page

  • @whu606 said:
    OK

    So you have to follow the instructions in the rest of my post.

    That debug line is not in Config.php but is in Config-defaults.php. Should I change it to true in that file? It says to amend the config.php file in the small print.

    I have a number of sub-cats in the Config.php file:
    //Conversations
    //Database
    //Enabled Applications
    //Enabled Plugins
    //Garden
    //Modules
    //Plugins
    //Whosonline
    //Routes
    //Vanilla

    If I am to insert the line in config.php which of these categories should I insert it under?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @whu606 said:
    OK

    So you have to follow the instructions in the rest of my post.

    ...

    in conf/config.php (add the line if it isn't already present, otherwise set 'false' to 'true'.)

    I'd put it on the last line, but I'm not sure it matters.

    I've closed your other thread about this issue. Please don't start multiple threads for the same issue.

  • K17K17 UnkornegLosk · Français / French Nouvelle Aquitaine / La Rochelle ✭✭✭

    @cckaadmin never edit the config-defaults.php file. Simply beacause config-defaults.php is overwritten on each update, and the config.php file not.
    If you have to change a setting present in config-default.php but not in config.php, simply copy the line from config-defaults.php and paste it into config.php file.
    That's what @whu606 said when he write:

    @whu606 a dit :

    in conf/config.php (add the line if it isn't already present, otherwise set 'false' to 'true'.)

    You can put it where you want in the config.php file. Those categories does not influence how settings will be applied. The only thing you have to care about, is if any other debug setting is present in config.php, because it can prevent debug from working. You said they have ni ither debug line so place it where you want.

  • @whu606 said:

    I've closed your other thread about this issue. Please don't start multiple threads for the same issue.

    Thanks. Can you confirm if I should also delete 'empty', '.DS_Store' and '.gitkeep' files in the cache. There is also a folder called ' Minify', should I also delete this?

  • cckaadmincckaadmin New
    edited November 13

    ok, I inserted the line into the config.php and tried to register. Got this error message:
    'View not found. The view you were looking for could not be found.'

    These lines were below:
    Trace

    0 /home/cckacouk/public_html/forum/library/core/class.controller.php(847): notFoundException('View')

    1 /home/cckacouk/public_html/forum/library/core/class.controller.php(704): Gdn_Controller->fetchViewLocation('/home/cckacouk/...', 'entry', 'dashboard')

    2 /home/cckacouk/public_html/forum/library/core/class.controller.php(1242): Gdn_Controller->fetchView('', false, false)

    3 /home/cckacouk/public_html/forum/library/core/class.pluggable.php(199): Gdn_Controller->xRender()

    4 /home/cckacouk/public_html/forum/applications/dashboard/controllers/class.entrycontroller.php(1357): Gdn_Pluggable->__call('render', Array)

    5 /home/cckacouk/public_html/forum/applications/dashboard/controllers/class.entrycontroller.php(1275): EntryController->registerApproval('')

    6 /home/cckacouk/public_html/forum/library/core/class.dispatcher.php(326): EntryController->register('')

    7 /home/cckacouk/public_html/forum/index.php(44): Gdn_Dispatcher->dispatch()

    8

    Debug Trace
    Info
    View Paths: array (
    0 => '/home/cckacouk/public_html/forum/plugins/BotStop/views/registerapproval.php',
    1 => '/home/cckacouk/public_html/forum/themes/default/dashboard/views/entry//home/cckacouk/public_html/forum/plugins/BotStop/views/registerapproval.php.',
    2 => '/home/cckacouk/public_html/forum/themes/default/views/entry//home/cckacouk/public_html/forum/plugins/BotStop/views/registerapproval.php.
    ',
    3 => '/home/cckacouk/public_html/forum/applications/dashboard/views/entry//home/cckacouk/public_html/forum/plugins/BotStop/views/registerapproval.php.*',
    )

    I was getting debug messages across the forum in every post so I have removed the debug line from the config.php

Sign In or Register to comment.