Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Errors on a new Vanilla forum

edited August 2006 in Vanilla 1.0 Help
Ok, so I've installed Vanilla at http://www.themacnurse.com/backend/forum , and it's a great tool. However, we've got some errors. Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/forum/extensions/Statistics/default.php on line 83 Warning: fopen(/var/www/forum/extensions/Statistics/options.inc): failed to open stream: Permission denied in /var/www/forum/extensions/Statistics/default.php on line 58 Warning: fwrite(): supplied argument is not a valid stream resource in /var/www/forum/extensions/Statistics/default.php on line 59 Warning: fclose(): supplied argument is not a valid stream resource in /var/www/forum/extensions/Statistics/default.php on line 60 Warning: main(/var/www/forum/extensions/DeliciousBookmarks/default.php): failed to open stream: No such file or directory in /var/www/forum/conf/extensions.php on line 21 Warning: main(): Failed opening '/var/www/forum/extensions/DeliciousBookmarks/default.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/forum/conf/extensions.php on line 21 The first four relate to the statistics module, and the next two the delicious bookmarks. I had to remove delicious from the server, because it caused a fatal error, and now I need to get rid of all these errors. Can anyone help?

Comments

  • Options
    Looks like you've got some wacky file permissions there. Try chmodding all your extension folders to 644.
  • Options
    Ok, will try that after a reinstall. I've just wiped it first.
  • Options
    edited August 2006
    644 is for the files, but you need 755 for the folders.

    If you have shell access, a good way the change the mode of your files and folders is:
    find /path/to/extensions/ -type d | xargs chmod 755 find /path/to/extensions/ -type f | xargs chmod 644
  • Options
    MarkMark Vanilla Staff
    edited August 2006
    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /var/www/forum/extensions/Statistics/default.php on line 83 Warning: fopen(/var/www/forum/extensions/Statistics/options.inc): failed to open stream: Permission denied in /var/www/forum/extensions/Statistics/default.php on line 58 Warning: fwrite(): supplied argument is not a valid stream resource in /var/www/forum/extensions/Statistics/default.php on line 59 Warning: fclose(): supplied argument is not a valid stream resource in /var/www/forum/extensions/Statistics/default.php on line 60

    In case you didn't notice, these are all associated with the Statistics extension. I may be wrong, but...

    1. The first error appears because the author used a query that your version of mysql doesn't understand.
    2. The second error appears because either your server doesn't allow the use of fopen, or the file itself was inaccessable due to file permissions.
    3. The third and fourth errors appear because of the second error.

    Warning: main(/var/www/forum/extensions/DeliciousBookmarks/default.php): failed to open stream: No such file or directory in /var/www/forum/conf/extensions.php on line 21 Warning: main(): Failed opening '/var/www/forum/extensions/DeliciousBookmarks/default.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/forum/conf/extensions.php on line 21

    Both of these errors appear because you've got a DeliciousBookmarks extension included in your conf/extensions.php file that doesn't appear to exist in your extensions directory.
  • Options
    edited August 2006
    Mark, I think you mean conf/extensions.php.
  • Options
    MarkMark Vanilla Staff
    That's right, a_magical_me. Corrected :)
This discussion has been closed.