Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Attachment 1.4

edited October 2006 in Vanilla 1.0 Help
I just installed Attachment 1.4. Specifically, I unzipped the contents in the extensions directory, then enabled the extension in settings. I am receiving an index error:

Notice: Undefined index: ATTACHMENT_DISPLAY_IMAGE_PROCESSING in /home/ualrsba/public_html/forums/extensions/Attachments/default.php on line 532

It would appear that the Attachment 1.4 should have made some SQL change, but did not. I also am unable to set any Attachment settings.

Any tips on what I might do?

Comments

  • Hi BenWilson. Attachments 1.4 works without SQL. The error you're receiving is because a setting is missing. You'll have to manually add the following to your conf/settings.php file:
    $Configuration['ATTACHMENT_DISPLAY_IMAGE_PROCESSING'] = 'None';
  • jazzman, i have this error:

    another problem... when i upload a zip file:
    the upload works, but when i download the file and open it in NOTEPAD it contents:


    Warning: readfile(/homepages/15/d83103864/htdocs/coolr.de/uploads/0.ilogo2_flyer.zip) [function.readfile]: failed to open stream: No such file or directory in /homepages/15/d83103864/htdocs/coolr.de/extensions/Attachments/default.php on line 200
  • Mmm.. this doesn't look good: 0.ilogo2_flyer.zip. The zero in front of the file implicates that the CommentID is missing... When you mouse over the attachment download URL, what does it say?
  • edited September 2006
    im picking up this error when i try to make a new post:

    Fatal error: Call to undefined function DiscussionForm_ValidateAttachments() in /home/user/public_html/vanilla/library/Framework/Framework.Class.Delegation.php on line 36
  • edited September 2006
    Now I'm getting the following notice

    Notice: Undefined index: REWRITE_extension.php in /home/ualrsba/public_html/forums/library/Framework/Framework.Functions.php on line 453

    EDIT: Disregard. I fixed. I should have searched first.
  • I have the exact same problem as outbreak:

    "Fatal error: Call to undefined function: discussionform_validateattachments() in /usr/local/psa/home/vhosts/zeptonn.nl/httpdocs/vanilla/library/Framework/Framework.Class.Delegation.php on line 36"

    help!
  • yeah, i'd really like to be able to use 1.4 - does anyone know what the hell is going on with that? i can't figure it out for the life of me.
  • I've fixed it

    Download Attachments 1.4.1
  • now it works, but the settings won't remember the image processing selection. so instead of popping up the image via lightbox/thickbox, it stays set to "none."
  • *raises hand*
    I´m too stupid to get it to work, too. ;)

    When I try to upload a file, I get the following error massage:

    ===
    Warning: move_uploaded_file(/kunden/70001_45665/fuenfarth/vanilla/uploads/2.raritan_briefing.pdf): failed to open stream: No such file or directory in /kunden/70001_45665/fuenfarth/vanilla/library/Framework/Framework.Class.Uploader.php on line 90

    Warning: move_uploaded_file(): Unable to move '/tmp/phpCMWB0Y' to '/kunden/70001_45665/fuenfarth/vanilla/uploads/2.raritan_briefing.pdf' in /kunden/70001_45665/fuenfarth/vanilla/library/Framework/Framework.Class.Uploader.php on line 90

    Notice: Undefined index: ATTACHMENT_CHMOD in /kunden/70001_45665/fuenfarth/vanilla/extensions/Attachments/default.php on line 169
    ===

    My shared hosting account starts at "/kunden/70001_45665/", the root of the domain starts at "/kunden/70001_45665/fuenfarth/". I´m not sure - maybe the problem is that the script cannot access "/tmp/phpCMWB0Y'"?

    Just to make sure I already chmodded "'/kunden/70001_45665/fuenfarth/vanilla/uploads/" to 777.
  • Has anyone else encountered the problem with either version 1.4 or 1.4.1 where no close image appears in the 'bottomNav' div for the a id='bottomNavClose' element?
    I've verified that the images are indeed there, and the previous and next images appear as they are referenced from the css, but for some reason, the close image and the loading images do not seem to appear. I've checked the reference in the lightbox.js file, but can't seem to get it to work.

    If anyone else has any other information it would be helpful.
  • edited October 2006
    It might be a friendly url issue

    http://lussumo.com/community/discussion/2803/search-engine-friendly-urls-breaks-extension-manager/#Item_10
This discussion has been closed.