Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Not logging IP addresses

edited September 2006 in Vanilla 1.0 Help
I am using version 1.0.1 and I have Log & monitor all IP addresses turned on. For some reason Vanilla is not keeping track of IP addresses. For example, I logged into my account from a different IP, nothing changed. Users are logging in from work/home/etc. and the IP seems to be frozen at the one they signed up with. Extensions shouldn't interfere with Vanilla's core functions, should it? Just in case, I have the following extensions installed:

Account Pictures, Add Comments. Announcement, Atom, Calendar, Category Jumper, Comment Protection, Comment Removal, Comments Permalinks, Discussion Filets, Edit In Place, Guest Welcome, HTML Formatter, Legends, Mark All Read, Next Unread Discussion, Notify, Panel Lists, Post Preview, Quicktags, Quote Text, Role History, RSS2, Saved Searches, Smooth Page Jump, Spell Checker, Style, Text Mode, ToDo, User Filters, User Info Tooltip, Whisper Notification, Yellow Fade

User Info Tooltip is the only one that remotely has anything to do with IPs. Vanilla is properly tracking the time members access the board but IPs are never updated.

Any advice you might have is greatly appreciated. :)

Comments

  • I am having the exact same problem. I also have IPHistory 1.0 installed
    neither the "last used IP" or the "IpHistory" is working.

    To the techies: The SQL database DOES have the IP information. I tried copy and pasting the extension into the account profile php page. Which actually showed some improvement. I was able to see the actual IP history header as well as a message that went something along the lines of "it does not appear that this user has any IPs logged". Since the IPs actually are logged, it probably means that the reference to them is broken somewhere.
  • I'm glad I'm not the only one. Yes, the IP data does seem to be in the database. When I disable the add-on the IPs still are not updated.
  • This seems to be a bug in vanilla. When I do a search for a user, and click on their name, the plug is not used, yet the last IP displayed is the one they used to sign up with their account, not the last IP they logged in with, which is being pulled in as the remote IP in the database for comments.

    Is there a way to change vanilla from pointing to the remote IP when a person signs up to the remote ip in the comments?
This discussion has been closed.