Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla Porter error for IPB 3.4.7

This discussion is related to the Vanilla Porter addon.
muqaddarmuqaddar New
edited December 2017 in Vanilla 2.0 - 2.8

Hello,

I'm trying to convert from IPB 3.4.7 with the Porter tool.

Source:
IPB 3.4.7, PHP 5.3

Destination:
PHP 7.1 (then Vanilla 2.13)

When I navigate to the porter file, I have this error:

Parse error: syntax error, unexpected '[' in /home/webapps/forum/uploads/vanilla2export.php on line 12238

I checked the file, and the line is:

$corruptedRecords = [];

I have no idea if what can be the issue ? Thanks in advance,

Comments

  • I have not the issue with the previous Porter (2.2) and can see the management console of the Porter. Can I use it to import to last version of Vanilla 2.3 ?

  • Using the 2.3 converter and commenting the section exportUserNotes() works now... (Remember =>no user notes on IPB) according to the Data currently supported per platform.

Sign In or Register to comment.