Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Upgrading from Vanilla 2.0 - 2.3 [RESOLVED]

wneumannwneumann New
edited December 2017 in Vanilla 2.0 - 2.3

I have a client who has an old website that uses Vanilla version 2.0.17.8. The website was inaccessible for an extended period of time due to several errors. The client sought help from several people, but the site was never recovered. I was finally able to work through the errors and get the site working, but this meant the site wasn't being upgraded for a long time. Now we want to upgrade to Vanilla 2.3.1 and republish the site (right now, I'm just running it on my local web server). However, the DDL statements we have from the old site, which are many thousands of lines long and contain years-worth of forum content, cannot be run easily in the new database for 2.3.1 since the database structure has changed. For instance, the field "CommentActivityID" no longer exists in the table GDN_Activity. Rather, there is a new table called GDN_ActivityComment that appears to handle that information now. I've tried the typical upgrade method of using utility/upgrade, but to no avail. Does anyone have any tips on how to deal with the database version differences?

Comments

  • Update: I discovered that domain/utility/structure can be used to update the database structure. However, when I ran the auto-generated database update script, I got the following error:

    Incorrect datetime value: '0000-00-00 00:00:00' for column 'DateSetInvitations' at row 17
    Field 'ProfileHeadline' doesn't have a default value|Gdn_Database|Query|insert GDN_ActivityType (`Name`) values (:Name)
    

    Searched the forums and I can't find anyone else with a similar error.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    AfaIk, the recommended path in this circumstance is to upgrade from 2.0 to 2.1 first, then upgrade to 2.3.

    Not sure if that will help you with this though.

  • Thanks. I wasn't sure how to incrementally upgrade, but after spending several hours working through issues and making my own changes to the database, I finally completed the upgrade successfully to 2.3.1.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Glad you got it working.

Sign In or Register to comment.