Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

In this Discussion

Invalid String Value for User Activity

I've upgraded our forum at https://forum.rumahilmu.or.id to Vanilla 2.5 - everything work normally, new discussion posting also work perfectly

Except when I tried to write activity for my account or send comment for other user activity it was failed. Error message :

Incorrect string value: '\xB4\xF2\x9B

I've tried to change database collation from utf8_unicode_ci to utf8mb4_unicode_ci but nothing change

Please help

Regard,
Reza Ervani
Rumah Ilmu Indonesia

Comments

  • I found this problem occured from Table GDN_Log

    Any solution ?

    Regard,
    Reza Ervani
    Rumah Ilmu Indonesia

  • After try to change Collation for Column InsertIPAddress in Table GDN_Log, error message still appeared, but now it looked like the problem come from Table GDN_Activity Column InsertIPAddress

    I've tried to change Table Collation but nothing change

    Any suggestion ?

    Regard,
    Reza Ervani
    Rumah Ilmu Indonesia

  • edited 10:58AM

    [PARTIALLY SOLVED]

    After learn SQL command at /utility/structure I found problem is Column InsertIPAddress at GDN_Activity table still use varchar(15), after change it manually from phpmyadmin into varbinary(16), voila ... error message was gone

    I don't know why database structure not change after do scan and execute it from vanilla dashboard (/utility/structure), so I still think to try to check and change all column manually.

    Any better solution ?

    Regard,
    Reza Ervani
    Rumah Ilmu Indonesia

  • After execute one by one SQL Query from /utility/structure with phpmyadmin, there are still 3 SQL Query can not be executed :

    alter table GDN_AccessToken
    add DateExpires timestamp not null after InsertIPAddress,
    add Attributes text null after DateExpires,
    character set utf8mb4 collate utf8mb4_unicode_ci,
    convert to character set utf8mb4 collate utf8mb4_unicode_ci;

    update GDN_User User
    set Permissions = ''
    where Permissions <> '';

    insert GDN_UserMeta
    (UserID, Name, Value)
    values ('0', 'stubcontent.record.locale', 'en');

    1. SQL Error for alter table GDN_AccessToken looked like :

    1067 - Invalid default value for 'DateExpires'

    1. There is no error for update GDN_User User but it keep appeared after rescan at /utility/structure

    2. Error for insert GDN_UserMeta is :

    1062 - Duplicate entry '0-stubcontent.record.locale' for key 'PRIMARY'

    Any helps ?

    Thank you

    Regard,
    Reza Ervani
    Rumah Ilmu Indonesia

Sign In or Register to comment.