Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

I get internal error when starting a new discussion

So i dont know what is going on and where to check.
So i start a new discussion, enter some title and some test, and click post discussion. The button gets gray, and it stays like that for a while. After some time i get a popup saying that i got an internal error.
If i look at the forum i see that the discussion got posted, but not with the tags (i have the tags plugin).

I dont know where to look. I mean i looked in the error logs and i eventually see the script ending error, but thats it. I dont see what script exactly.
I tried to disable all the plugins except the one that come built in.
I also upgraded to 2.5 from 2.3.1.

What can i check ? Where to start ?

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Tagging has become a core feature. Maybe the plugin interferes with 2.5. Try

    a) deactivating the tagging plugin
    b) delete it
    c) check that the tagging functionality is correctly set up (example.com/settings/tagging)

    Before you do so, back up your installation folder and the database.

  • RiverRiver MVP
    edited February 13

    after you follow above instructions

    also run utility/structure and utility/upgrade

    and also verify your roles and permissions with regards to tagging.

    you can also see a few more config statements get added to config.php

    https://github.com/vanilla/vanilla/search?p=1&q=tagging

    also UPGRADE to vanilla 2.5.1 - since there are security fixes.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • So i deleted the content of "Tagging" folder and removed the line from the config file. I see that i have an option for "Tagging" in the dashbord menu.
    I ran those links, but it behaves the same.
    What else can i check ?

  • RiverRiver MVP
    edited February 14

    @fxandrei said:
    So i deleted the content of "Tagging" folder and removed the line from the config file. I see that i have an option for "Tagging" in the dashbord menu.
    I ran those links, but it behaves the same.
    What else can i check ?

    did you run utility/structure? did you upgrade to vanilla 2.5.1?

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Yes i did. I get :
    update GDN_User User
    set Permissions = ''
    where Permissions <> '';

    insert GDN_UserMeta
    (UserID, Name, Value)
    values ('0', 'stubcontent.record.locale', 'en');

    I click "Run Structure ....", but i still get the same text if i run it again.
    Do you think this has something to do with it ?

  • RiverRiver MVP
    edited February 14

    @fxandrei said:
    Yes i did. I get :
    update GDN_User User
    set Permissions = ''
    where Permissions <> '';

    insert GDN_UserMeta
    (UserID, Name, Value)
    values ('0', 'stubcontent.record.locale', 'en');

    I click "Run Structure ....", but i still get the same text if i run it again.
    Do you think this has something to do with it ?

    no that's fine those are the usual messages. You could disable the stubcontent plugin if it is enabled.

    If you disable tagging do you get an internal error? when posting.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Yes. I tried disabling most of the plugins available, and still get the same thing.
    The only one i had enabled was "Private Community".

  • So with tagging disabled you get a posting internal error? is that correct.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Yes. So like i said, i deleted the content of Plugins\Tagging because i saw its empty in the archive ... So i deleted, and also deleted "$Configuration['EnabledPlugins']['Tagging'] = true;" from the config.
    Then i saw that i can still have taggs.
    Anyway, i left it disabled. I still disabled most of the plugins, except "Private Community", and i still get that error.
    The thing is that the discussion gets posted, its just that i get this error. So if i click post discussion, nothing happens. And i wait. After a while i get the internal error message.
    But the discussion actually gets posted immediatly after i click the button (i start a new tab, and i can see it).

  • RiverRiver MVP
    edited February 14

    good explanation. For a test. I would disable all the plugins and use a default theme including Private Community if possible and see if you still have a problem.

    You could temporarily change things in Roles and permssions to make sure non admin users can view discussions if you are concerned with privacy while testing wihout using privacy plugin.

    check .htaccess if using apache

    if the error happens all the time after you disable ALL plugins and use default theme could be resources are taxed.

    then enable one plugin at a time to test if you get no internal error when posting to isolate problem.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • So i disabled all the plugins, cleared the cache, and used the .htaccess.dist (removed dist). Still the same thing. I think im running out of options :).

  • RiverRiver MVP
    edited February 14

    try this .htaccess

    https://github.com/vanilla/vanilla/blob/Vanilla_2.2/.htaccess

    also after switching to the .htaccess above

    uncomment and edit the line https://github.com/vanilla/vanilla/blob/Vanilla_2.2/.htaccess#L8

    to reflect where your forum folder is located.

    also test with set $Configuration['Debug'] = FALSE; in your conf/config.php.

    sometimes trying to debug causes unpredictable errors.

    back up your database and config.php then

    if you still have posting issues. try installing a test 2.5.1 installation in a test folder with a new database. then if no problems you can restore old database to see if you have problems.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Same thing.
    Although i get a new error in the logs :
    AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

  • RiverRiver MVP
    edited February 14

    is vanilla embedded?

    sounds like a problem with .htaccess.
    what folder is your vanilla located in? root, in /forum or somewhere else?

    post your .htaccess

    determine what version of php you are using?

    also make sure rewriteurls is set in config.php

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • PHP Version 7.0.10

    Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /fo$
    RewriteBase /home/forum/public_html
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    If i put $Configuration['Garden']['RewriteUrls'] = TRUE; in the config, i get internal error when clicking new discussion.

    By the way, the internal error i got untill now is in a popup. After some time after i click post, i get a popup saying "Internal error....".

    If i add the line in the config i get the internal error thing on the whole page.

  • RiverRiver MVP
    edited February 15

    check if php has rewrite enabled.

    https://stackoverflow.com/questions/7337724/how-to-check-whether-mod-rewrite-is-enable-on-server

    you should ask your host where your root folder is for web server and base your forum off of that.

    not sure if you need.

    RewriteBase /home/forum/public_html

    or

    RewriteBase /forum/public_html

    or

    RewriteBase /public_html

    or

    RewriteBase /

    if 2.3.1 worked for you in the past, I would use the same .htaccess you had before if you were rewriting urls, which seems to work better with regards to odd vanilla errors.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • So im the host :) . I have access to everything on the host.
    So i have this in apache :
    DocumentRoot /home/forum/public_html
    RewriteEngine on

    I am now using the .htaccess.dist file content (removed the .dist).

    The problem i am having was present for me in version 2.3.1 as well.

    So what can i check ?.
    PS: i have virtualmin on centos7

  • RiverRiver MVP
    edited February 16

    try

    RewriteBase /

    with your current .htaccess

    otherwise try and

    uncomment and edit the line with this .htaccess

    https://github.com/vanilla/vanilla/blob/Vanilla_2.2/.htaccess#L8

    and add

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    to your config.php

    and verify as I said if the rewrite module is enabled.

    https://www.digitalocean.com/community/tutorials/how-to-set-up-mod_rewrite-for-apache-on-centos-7

    after you verified that mod_rewrite is enabled and you have mofdiefied the config.php, and the htaccess to reflect RewriteBase /

    the idea is to solve this first....

    AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error

    then move on.

    https://www.google.com/search?&q=virtualmin+centos+htaccess+errors&oq=virtualmin+centos+htaccess+errors

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

Sign In or Register to comment.