Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Can't update from version 2.1 to 2.5 without major breakage

To upgrade I followed these steps:
backed up config, and kept the original copy in /conf/
kept back /plugins/ /themes/ and /uploads/ as well
Went to /utility/update. It says "update successful" but the plugin for jsConnect says 1.0.3b despite my deleting that one from the plugins folder and replacing it with the latest version (1.5.4).
It also doesn't rewrite URLs despite the $Configuration['Garden']['RewriteUrls'] line being deleted and my nginx being configured to rewrite them.

If I copy the config-defaults, add in my database information, and copy the 3 "installed" lines from the previous configuration, and then go to /utility/update, it says successful. But then I get 404 pages for my forum.example.com page, /discussions. /dashboard works and says "vanilla is installed" but that's all that seems to work.

Comments

  • SadtacoSadtaco New
    edited February 26

    Also /utility/structure lists changes when I scan using the old config, but when I "run structure & data scripts" it does nothing and rescan shows the same output.

    Though it seems to have worked when I did a more clean install without the old themes/plugins/etc... Except that url rewrites still don't seem to work.
    I can go to forum.example.com/discussions fine but when I click on discussions it gives the index.php?q=/discussions URL.

    And though the jsConnect configuration works and it no longer returns JSON in some error in the bottom left corner, it still lists version 1.0.3b and I don't see the SSO option on my forum like I did before.

    edit: jsConnect seems to have worked after I changed some other option. I had popup disabled and had to change something up. But now I can't see what because connecting through JsConnect stripped me of my admin powers.

  • Actually jsConnect seems to have worked after I changed "Make this connection your default signin method." on as well. I had popup disabled like it recommended but needed that other option, too. For some reason, the dashboard link is now gone on that user, but "moderation queue" and such still shows and I can get to the dashboard manually.

    But other than that and the URLs not being "prettied" when clicking links in Vanilla, I guess it's working now...

  • UKguyUKguy
    edited February 26

    How about downloading the sql file then installing a brand new install then replace the new sql with the old one, when you install the latest vanilla cms, use the same database name as the one you have now.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @Sadtaco said:
    It also doesn't rewrite URLs despite the $Configuration['Garden']['RewriteUrls'] line being deleted and my nginx being configured to rewrite them.

    Keep $Configuration['Garden']['RewriteUrls'] = true; in your /conf/config.php

  • SadtacoSadtaco New
    edited February 26

    @R_J said:

    @Sadtaco said:
    It also doesn't rewrite URLs despite the $Configuration['Garden']['RewriteUrls'] line being deleted and my nginx being configured to rewrite them.

    Keep $Configuration['Garden']['RewriteUrls'] = true; in your /conf/config.php

    Odd. The default config has no such option.
    It was my understanding that that option was removed and it just rewrites by default.

    Putting that in did fix it, though.

Sign In or Register to comment.