Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Successful login takes two attempts

edited October 2007 in Vanilla 1.0 Help
I just created my vanilla forum a week ago. I have about 60 users registered. I'm starting to notice that it takes two login attempts before I'm authenticated. What are some tips to troubleshoot the root cause of this behavior? Has anyone else seen this behavior?


  • Options
    I don't think that this has anything to do with Vanilla ... may be just bad keyboard? or typing fast?
  • Options
    MarkMark Vanilla Staff
    I've seen this happen before. Make sure that your FORWARD_VALIDATED_USER_URL configuration setting exists and points to your discussions index.

    If you sign in and it puts you back to the sign in page, try to manually change the url to point at your discussions index to see if you are actually successfully signed in. If you are, then it is definitely a redirecting error and probably has something to do with that FORWARD_VALIDATED_USER_URL setting.
  • Options
    I am experiencing the same problem (it takes two login attempts to get logged in)

    from the /conf/settings.php file:

    $Configuration['WEB_ROOT'] = '/vanillaforum/';
    $Configuration['BASE_URL'] = '';
    $Configuration['FORWARD_VALIDATED_USER_URL'] = '';

    Is this not correct? This should bring up 'index.php', right?

    After the first attempt, the url in the browser's (Firefox) address line is:

    My hosting is linux with php 4.3.11, MySQL 5.0.18. Vanilla 1.0.3
  • Options
    What's wrong with that address line?
  • Options

    This is also on the address line when I first access the site. So I am not sure - is there something wrong with the address line? I think that I have configured Vanilla correctly. I notice that the Lussumo Community address when signing in doesn't have the 'SignOutNow" part - but I don't know why it puts that there on my installation.

    Anybody have any suggestions?
  • Options
    I see. What's your SAFE_REDIRECT_URL in the config file?
  • Options
    I had the same problem, at first time (fresh install Vanilla 1.1.2)

    1) I must change
    $Configuration['COOKIE_DOMAIN'] = ''; <== <b>empty str NOT 'localhost'
    $Configuration['COOKIE_PATH'] = '/vanilla/';

    2) Then
    $Configuration['WEB_ROOT'] = '/vanilla/';
    $Configuration['BASE_URL'] = '';
    $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; <== NOT <b>'localhost/vanilla/'

    Now Sign In works at one attempt.

    R- JoH
  • Options

    What config file are you referencing?

    I cannot find a file named 'config' in the entire directory structure. However, in the file 'settings.php' under the 'appg' directory, it has a line that reads:

    $Configuration['SAFE_REDIRECT'] = 'people.php?PageAction=SignOutNow';

    Is this the setting you were referencing? If so, what should it be? This was configured by my hosting's automatic installer (godaddy).

    Thanks much!
  • Options
    Yeah that's what I was looking for but that value looks fine. Are you still having this problem?
  • Options
    It is still a problem for my site, and I have determined that it is affecting users who are accessing with Mozilla Firefox. Under IE it is not a problem.
  • Options
    Well that is an odd one. I'd expect it to be the other way round...hmmmm.
  • Options
    Interesting note: it isn't a problem when accessing this forum with Firefox.
  • Options
    edited October 2007
    Turns out the comment I posted on was incorrect. The problem occurs on both IE and Firefox and oddly seems to be "cleared" by logging in successfully using a different username. I'm wondering if it has something to do with people not logging out of the application and cookies not expiring correctly. Unlike the first report of the problem, the 2nd attempt also fails, as does the 3rd, 4th, etc. Similar to the first report though, the URL after the failure shows: people.php?PageAction=SignOutNow...
  • Options
    For what its worth, we figured out the problem. I'm posting it here in case any one else runs into a similar problem. Basically, this is a problem that occurs because IIS is NOT case sensitive. The primary link to the vanilla installation was something like whereas it was configured in vanilla as So there was a disparity between the URL and the cookies and the cookies couldn't do their job.
This discussion has been closed.