Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Getting 404 when I try to change profile picture [RESOLVED]

edited April 2018 in Vanilla 2.0 - 2.8


I had recently updated my forum from 2.4b to 2.5.1 and the only issue that I have is that I can't change my profile picture.

Vanilla doesn't find any defined route for this two URL's:

profile/picture?userid=2&DeliveryType=VIEW (this URL is loaded inside a modal)

I tried deleting my cache folder, disabling pretty url's and disabling Gravatar plugin without success.

Thanks in advance.


  • nikoskipnikoskip
    edited April 2018

    I just tried a clean install with the same result O.o

    My stack:

    nginx 1.13.9
    PHP 7.2.2
    MySQL 5.7.21 (with strict mode disabled)

  • R_JR_J Ex-Fanboy Munich Admin

    how does your nginx server file look? Could you please try something like that:

        location / {
            try_files $uri $uri/ @vanilla;
        location @vanilla {
            rewrite ^/(.+)$ /index.php?p=$1 last;
  • Hi @R_J

    I'm currently using that configuration:

    I first blame nginx, but I tried disabling pretty url's with same result. I was debugging using Xdebug and the request enters to my index.php but Vanilla doesn't find any valid route for the URL and throw a 404.

  • R_JR_J Ex-Fanboy Munich Admin

    Even index.php?p=/profile/picture throws a 404 error on a clean install?

  • nikoskipnikoskip
    edited April 2018

    Even index.php?p=/profile/picture&userid=2&DeliveryType=VIEW throws a 404.

    I really don't know what is wrong with my installation.

  • nikoskipnikoskip
    edited April 2018

    I found the problem: I move out my forum to a new server and it was missing the PHP GD extension. So, Vanilla was throwing a 404 instead a 500. Maybe the requirement of PHP GD should be added to the README.

    The $Configuration['Garden']['Errors']['LogFile'] configuration was very helpful to figure out the problem.


  • R_JR_J Ex-Fanboy Munich Admin

    I've posted your suggestions on GitHub where they will get more attention than here. Thanks for your detailed feedback!

Sign In or Register to comment.