Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Registration Restrict Logger Plugin not working with 2.5.1

This discussion is related to the Registration Restrict Logger addon.

After I upgraded to Vanilla version 2.5.1, the Registration Restrict Logger plugin doesn't seem to work. The settings page doesn't come up in the dashboard, and the spam registration, which used to be blocked (particularly those starting with "{I want to {" are now coming through.

I upgraded to the latest version of the plugin (2.3) and it still has the same problem.

Can someone confirm whether it's working for them?

Thanks.

Comments

  • RiverRiver MVP
    edited April 12

    @brainolution said:
    After I upgraded to Vanilla version 2.5.1, the Registration Restrict Logger plugin doesn't seem to work. The settings page doesn't come up in the dashboard

    I upgraded to the latest version of the plugin (2.3) and it still has the same problem.

    There is no Settings Page in the plugin I downloaded (as far as I can tell) , the readme even says there is no settings page.

    Have you read the readme.txt. It would be a good idea.

    it states ---- there is no settings page yet!

    Did you upgrade the plugin properly ( a fool-proof way for all plugins)

    • Disable the plugin in dashboard.
    • Delete the old addon folder from your plugin folder. (don't rename - delete or move it to your local computer)
    • Download the new addon , unzip and install folder in the proper folder where your plugins are located.
    • Next READ the readme.txt. follow the instructions if any carefully.
    • Next delete the addon.php from the cache folder.
    • enable the plugin in the dashboard.

    if after following the fool proof way to install the plugin the plugin author might provide you help if there is a problem. As you know vanilla 2.5.1 breaks many addons. But if you don't install plugins or read the readme carefully, you can break them as well.

    you can follow this guide above for all plugins.

    you have probably reported the plugin not working because you installed it incorrectly

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • @brainolution said:
    After I upgraded to Vanilla version 2.5.1, the Registration Restrict Logger plugin

    I upgraded to the latest version of the plugin (2.3).

    Can someone confirm whether it's working for them?

    Thanks.

    Yes. the plugin tested and works in 2.5.1

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Thanks for your response, @River

    I did all the steps exactly as you listed, except for deleting the addon.php in the cache folder. Today I disabled the plugin, deleted that file, and re-enabled the plugin. Let's see how it goes.

    The settings icon in the dashboard mislead me into thinking that there was a settings page too. I had not had the need to touch this plugin at all until I upgraded to Vanialla 2.5.1 recently. It had been working perfectly for about 2 years prior to that.

    So definitely the older version of the plugin stopped working after upgrade to 2.5.1. That made me switch to the latest version (2.3) of the plugin.

    I'll report back the findings in a few days.

  • A quick update, it seems to working now. I haven't had any spam registrations in the past 5 days.

    R_J
Sign In or Register to comment.