Invalid Emails

Hi,

with 2.5.1 my users reported that they received invalid emails. Here's the first one, it contains a pass word reset link, which is broken and if they click on it they land on an error page, of course:

Then I went to the dashboard and changed the default email format to HTML, which results in such mails:

I looked into the template for this mail, that blue rectangle on the bottom is supposed to be a button. The users don't even think about clicking this and click on the forum link above. Unfortunately this doesn't lead to the pass word reset page, so they need to repeat the process, receive the same invalid email, and so on.

Also note the various other rendering errors, invalid umlauts and scattered equal signs here and there. In one case the email has been blocked by the enterprise mail filters because of this.

best regards,
Tom

Comments

  • Hello,

    is there only support for commercial users available? I think this is a major bug and I don't understand why it doesn't seem to bother anyone. Or am I the only one who has a problem with non-functional emails?

    So, please, could anyone respond?

    Thanks,
    Tom

    PS: the same applies for to my other Thread.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @tomx

    This is a support forum for the open source community, and responses here are almost all from volunteers, so you (everyone) get what people can offer.

    That said, the software is identical, barring a few 'hosted only' plugins, so clearly, other users are not experiencing this in any numbers, or it would be a regular issue, so it is almost certainly down to your set up.

    Have you tried setting your theme to the default theme to rule out any conflicts?

    Have you tried disabling plugins to rule out a conflict?

  • Thanks for your response.

    I had the bootstrap theme enabled and switched back to standard. Now, text mails look as expected, besides the subject which is unencoded utf-8, but this is a rather minor disturbance.

    I'll let my users test again.

Sign In or Register to comment.