Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Forum won't load after changing settings

edited January 2008 in Vanilla 1.0 Help
I've been trying to move my forum to a new server and have been having all sorts of problems. I eventually ended up doing a fresh install, wiping the database, and using navitec (i don't have shell access) to move my old database data. Everything seems to go fine until I go into settings and uncheck anything. Once I change the settings the forum won't load. I tried just doing a fresh install and not moving the old database to see if that was causing the problem but even with the fresh install the settings problem keeps happening.

Comments

  • Options
    MarkMark Vanilla Staff
    Sounds like permission problems: http://lussumo.com/docs/doku.php?id=vanilla:administrators:troubleshooting#permission_problems
  • Options
    Hi Minimum,

    I would do the following:

    Check the server to make sure it meets the system requirements (which it probably does):

     Server Requirements: Vanilla can run on just about any web server in the world. To run Vanilla, you should have:

    * PHP 4.1 or greater
    * MySQL 3.23 or greater
    And then check that the directories/files have the proper permissions to run:

     Permissions: chmod 777 ./conf
    chmod --recursive 755 ./extensions
    chmod --recursive 755 ./languages
    chmod --recursive 755 ./setup
    chmod --recursive 755 ./themes
    If that doesn't work - I'd try reinstalling everything again.
  • Options
    thanks...i'll try stepping it down
  • Options
    @ barl0w - the settings were correct and i've tried uninstalling and reinstalling a couple of times. the new server is with mosso who are trying a new hybrid server system and have been hitting some bumps in the road. after pointing out the problem to them they told me to leave it alone while they try to figure it out. i did let them know about changing the chmod to 666 though.
  • Options
    I've tried uninstalling and reinstalling a few times and am still having problems. Right now I have it set to php5, mysql5, and cgi/perl enabled. The permissions ar chmod 777 ./conf, 755 ./extensions, 755 ./languages, 755 ./setup, 755 ./. themes. Everything seems to install correctly, but once I logout and close the browser it won't load. I've contacted tech support and they have no idea what the problem is but they do get the same error. I asked on the site forum if anyone was having a similar problem and one guy said he had it installed fine and no problem loading after logging off and on even after permission change. Any idea what I could be doing wrong or could ask the tech folks to check out for me?
  • Options
    I manage to resolve the issue that minimum is describing above. The issue on the Mosso servers is that you get a redirect loop when the settings are set to not allowing non-members to browse the forum. The solution I found was to edit the appg/settings.php file, change the
    $Configuration['SAFE_REDIRECT'] setting, that by default is set to people.php?PageAction=SignOutNow to a full path e.g. /myvanillainstall/people.php?PageAction=SignOutNow

    This should sort it out. Not sure if it is a Mosso issue or a Vanilla issue?
This discussion has been closed.