Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Lost access to dashboard home and other dashboard functionalities

happy2bhappy2b New
edited May 29 in Vanilla 2.6 Help

Hello!

We just upgraded from 2.3 to 2.6 (followed the instructions from https://open.vanillaforums.com/discussion/36260/vanilla-2-6-is-here-includes-security-fixes) but are struggling to get our forum admin CP to work. The front end is good but the back-end not so much. Can't access the plugins, the dashboard home, etc.

I have enabled the debug mode and you can see our various error messages at http://forum.laughteronlineuniversity.com/

Error 1) The addon with key HtmLawed and key Tagging could not be found and will not be started.
Indeed we deleted plugins/Tagging and plugins/HtmLawed as instructions said they are now part of core. How to fix?

Error 2) The addon in /themes/bootstrap has 1 issue(s).
Error 3) The addon key must match it's subdirectory name (Bootstrap vs. bootstrap).
Error 4) Declaration of MediaModel::Delete($Media, $DeleteFile = true) should be compatible with Gdn_Model::delete($where = Array, $options = Array)
Error 5) Declaration of MediaModel::GetID($MediaID) should be compatible with Gdn_Model::getID($iD, $datasetType = false, $optio\ns = Array)
Error 6) Gdn_PluginManager::registerHandler is deprecated.

No idea how to fix these.

We have seen https://docs.vanillaforums.com/developer/troubleshooting/#troubleshooting-vanilla
Deleting the plugins and reverting back to default theme did not fix anything.

What do you suggest we do?

Comments

  • /dashboard/settings/home gives the following error:

    Fatal Error in SettingsController.xsetHighlightRoute();
    The "SettingsController" object does not have a "xsetHighlightRoute" method.
    The error occurred on or near: /home/lou/forum.laughteronlineuniversity.com/library/core/class.pluggable.php
    184: // Make sure that $ActualMethodName exists before continuing:
    185: if (!method_exists($this, $actualMethodName)) {
    186: // Make sure that a plugin is not handling the call
    187: if (!Gdn::pluginManager()->hasNewMethod($this->ClassName, $referenceMethodName)) {
    188: trigger_error(errorMessage('The "'.$this->ClassName.'" object does not have a "'.$actualMethodName.'" method.', $this->ClassName, $actualMethodName), E_USER_ERROR);
    189: }
    190: }
    191:
    192: // Make sure the arguments get passed in the same way whether firing a custom event or a magic one.
    Backtrace:
    /home/lou/forum.laughteronlineuniversity.com/library/core/class.pluggable.phpPHP::gdn_ErrorHandler();
    [/home/lou/forum.laughteronlineuniversity.com/library/core/class.pluggable.php:188] PHP::trigger_error();
    [/home/lou/forum.laughteronlineuniversity.com/plugins/VanillaStats/class.vanillastats.plugin.php:129] Gdn_Pluggable->__call();
    [/home/lou/forum.laughteronlineuniversity.com/library/core/class.dispatcher.php:845] VanillaStatsPlugin->settingsController_home_create();
    [/home/lou/forum.laughteronlineuniversity.com/library/core/class.dispatcher.php:274] Gdn_Dispatcher->dispatchController();
    [/home/lou/forum.laughteronlineuniversity.com/index.php:29] Gdn_Dispatcher->dispatch();
    Variables in local scope:
    [methodName] 'setHighlightRoute'
    [arguments] array (
    0 => 'dashboard/settings',
    )
    [actualMethodName] 'xsetHighlightRoute'
    [referenceMethodName] 'setHighlightRoute'

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
    1. In your conf/config.php you still have Tagging and HtmLawed as Enabled plugins. You can delete those lines or ignore the warning
    2. Which errors? Might be solved with the next point
    3. If your theme is called /themes/Bootstrap make it /themes/bootstrap or the other way around
    4. ignore that
    5. ignore that
    6. I guess it could be ignored, too

    Delete the file applications/vanilla/controllers/class.settingscontroller.php

    Clear the cache (the smarty compiled files all theme related files and the addon.php)

    Afterwards everything should be functional

    Adrian
  • You shine! This fixed it and all is now working as it should. Thank you for your help. Much appreciated.

    Adrian
  • This fixed almost everything for me. The only page I can't get at is the registration page in the dashboard, I get this error:

    Unknown column 'Type' in 'where clause'
    The error occurred on or near: /vagrant/vanilla/library/database/class.database.php
    417:                 if (!$message) {
    418:                     $message = $ex->getMessage();
    419:                 }
    420: 
    421:                 trigger_error($message, E_USER_ERROR);
    422:             }
    423: 
    424:         }
    425: 
    Backtrace:
    /vagrant/vanilla/library/database/class.database.phpPHP::gdn_ErrorHandler();
    [/vagrant/vanilla/library/database/class.database.php:421] PHP::trigger_error();
    [/vagrant/vanilla/library/database/class.sqldriver.php:1684] Gdn_Database->query();
    [/vagrant/vanilla/library/database/class.sqldriver.php:629] Gdn_SQLDriver->query();
    [/vagrant/vanilla/applications/dashboard/Models/class.rolemodel.php:359] Gdn_SQLDriver->get();
    [/vagrant/vanilla/applications/dashboard/Controllers/class.settingscontroller.php:1538] RoleModel->getByType();
    [/vagrant/vanilla/library/core/class.dispatcher.php:845] SettingsController->registration();
    [/vagrant/vanilla/library/core/class.dispatcher.php:274] Gdn_Dispatcher->dispatchController();
    [/vagrant/vanilla/index.php:29] Gdn_Dispatcher->dispatch();
    

    Any ideas? The main reason I was upgrading was because reCaptcha 1 stopped working so I think I need to be able to get at the settings in this section.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Is there a complete sql clause shown?

    Have you tried to run yourforum.com/utiliy/structure ?

Sign In or Register to comment.