Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Server Install Error

Hi Team, I downloaded the latest vanilla 2.6, & push it to our server, replacing the old vanilla 2.2 folder. I tried pointing the config to new db (no data/structure) & tried pointing it to db with raw db (with data/structure from my successfull local install). Both gave me this error:

"PHP Fatal error: Uncaught Error: Call to a member function getPermissions() on null in /var/www/html/library/core/class.session.php:496\nStack trace:\n#0 /var/www/html/library/core/class.auth.php(59): Gdn_Session->start(false, false)\n#1 /var/www/html/bootstrap.php(346): Gdn_Auth->startAuthenticator()\n#2 /var/www/html/index.php(22): require_once('/var/www/html/b...')\n#3 {main}\n thrown in /var/www/html/library/core/class.session.php on line 496"

Has anyone experience this error? TIA

Sign In or Register to comment.