Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Internal Server Error

edited September 2006 in Vanilla 1.0 Help
I just installed vanilla to a subdomain on my server, and when I navigated to the page to start the install I got "Internal Server Error". I've used the version prior to 1.0.1 and everything worked fine when applied to a subdomain, but now I'm not able to get any further in the installation. Any ideas?


  • Without more details no. Do you have access to your error.log?
  • Where would I find that?
  • MarkMark Vanilla Staff
    edited September 2006
    Have you tested to see if php is working properly? Mysql? Versions?
  • edited September 2006
    php version is 4.3.6 and mysql is 4.0.18. php is working properly on other subdomains I have, and i've made a few more putting other files in them, and I'm not getting an Internal Server Error. It seems to only happen when I put all vanillas files in there.
  • Are you using the friendly urls addon and do you have any .htaccess files in the directory? Is the subdomain setup as a virtualhost in your apache config?
  • I'm not using any extensions seeing as I haven't installed yet. When I go to the page to begin the installation I get the Internal Server Error. The only .htaccess file in the directory is the one that came bundled with vanilla. I set up the domain by adding a new folder by creating a directory called "".
  • there's a .htaccess file bundled with vanilla now? in the root of the forum?
  • Yes. It was in the zip file I downloaded from In the root dir.
  • hmm... does it have a bunch of "RewriteRule xxxxx" stuff in it?
    if so, rename it to htaccess.txt until you have the forum working and the friendly urls extension installed.
  • You mean this?

    RewriteEngine On Options +FollowSymLinks -Multiviews #Discussions RewriteRule ^discussions$ index.php [QSA,L] RewriteRule ^discussions/$ index.php [QSA,L] RewriteRule ^discussions/([0-9]+)$ index.php?page=$1 [QSA,L] RewriteRule ^discussions/([0-9]+)/$ index.php?page=$1 [QSA,L] RewriteRule ^([0-9]+)$ index.php?CategoryID=$1 [QSA,L] RewriteRule ^([0-9]+)/$ index.php?CategoryID=$1 [QSA,L] RewriteRule ^([0-9]+)/([0-9]+)$ index.php?CategoryID=$1&page=$2 [QSA,L] RewriteRule ^([0-9]+)/([0-9]+)/$ index.php?CategoryID=$1&page=$2 [QSA,L]

    There's alot more in this file, but thats the beginning of it.
  • ithcyithcy New
    edited September 2006
    yeah. rename it.

    (or else change it to say 'RewriteEngine Off' at the top)
  • Thanks a bunch ithcy! Everything works now.
  • great :)
  • Is friendlyurls part of the core now then? Or was that a bug on marks behalf?
This discussion has been closed.