Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

2.6.1 New Install with Data from 2.0 Install

I inherited a Vanilla Forums 2.0 site, which had to be moved, so I started by downloading the latest Vanilla (2.6.1) and installing it at the new location and connecting it to a new SQL database. I exported the data from the old database and now I'm wondering if I can simply import the data into the new database since it is a different version of the software or do I need to use the Porter? Any recommendations would be greatly appreciated.


  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Welcome to the community.

    The porter plugin is not intended for Vanilla upgrades.

    You should be able to manage this by:

    Dropping the tables from your current 2.6 install (I'd make a backup first, even if it is only 'dummy' data.)

    Importing the tables from your 2.0 install.


    You may need to clear the files from your cache folder.

  • Options

    Thanks whu606. I used phpMyAdmin and received a message saying the data was imported, but when I try to navigate to the forum site or the dashboard I get a "Something has gone wrong" message. Should I have only imported the data (rather than the structure and the data)?

  • Options

    Apologies, I see your note said structure/all.

  • Options

    I have now exported and imported the 2.0 data multiple times directly via Apache command line, but still receive the "Something has gone wrong" message when I attempt to access the forum after importing. As suggested I tried running the following and clearing the cache, but each time get the error message above:

    I was able to import the dummy data back into the database and that worked without any problem.

    Any suggestions are greatly appreciated......

  • Options

    I just found this thread. I'll go through it. It looks like I need to turn on debug.

    I don't mean to waste anyone's time - once I get through the info reference above I'll reach out again if needed.

  • Options

    For anyone doing this upgrade from a 2.0 version without success, the thread referenced above is extremely helpful. Some of the data structure issues found by the debug tool were a bit unclear, but it did make clear the software would not work with my (old) Roles and Permissions tables. As soon as I replaced those with the ones from the new version of Vanilla, the forum came back online.

  • Options

    Glad to hear that the thread helped somebody else. It took a while for us to figure it out, and it actually spanned across multiple threads, but now it looks like we've got a method that works perfectly. I've updated that thread with a breakdown, just to make things easier for the next person.

Sign In or Register to comment.