Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Updating from 2.3.1 to 2.6.1

Carlo_13Carlo_13
edited September 2018 in Vanilla 2.0 - 2.8

Hi everyone.

I tried to update from 2.3 using this guide:


From Vanilla 2.3 or earlier:

  • Delete /applications/vanilla/controllers/class.settingscontroller.php.

If your forum still uses URLs including ?p=, support for this URL structure has ended. Follow these steps to switch to the simpler format:

  1. Confirm your server is setup to handle rewrites. On Apache, using the .htaccess file provided will accomplish this. Additional setup is required on nginx and other platforms.
  2. Test whether it is working by visiting /discussions - if you see a discussions list (rather than a 404), it is likely setup correctly.
  3. Open /conf/config.php and find the line with $Configuration['Garden']['RewriteUrls'] = false; and delete the entire line.

Your site should immediately switch to "pretty" URL paths instead of using the 'p' parameter. If there is a problem, re-add the line to your config and do further troubleshooting.


Unfortunately my forum went blank.

Any idea what I am doing wrong ? Should I delete all my themes and plugins ?

Thanks for your help.

P.S.: By the way, if it can help this is my server config => php7 (FPM application server by Apache), linux server, ngnix also running.

Comments

  • UPDATE:

    So I delete all my plugins, activated the baseline theme, and the update was successful!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    OK

    So now you can re-enable your theme, and then your plugins one at a time, until you find the one that caused the issue.

    Bleistivt
Sign In or Register to comment.