Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Moving to domain.com/subdirectory from another forum.domain.net

I'm planning to move my Vanilla "forum.domain.com" to "domain.net/forum" (with WP on its root). What are your thoughts? Have anyone tried this before? Could I have some tips? Thanks.

Comments

  • edited September 9

    Shouldn't be an issue at all. after you make the change, and visit "domain.net/forum", as long as you have the vanilla directory in that location, it'll adjust to that.

    I recently went from "domain.net/forum" to "domain.net/forum2", which is essentially the same thing, and everything is normal.

    I'd wait for one of the professionals to confirm, but i'm almost positive it'll be fine. It's not like you'd be deleting anything off the server anyway, so if there's an issue, you could always revert back.

    Edit:

    I misread that a little. Are you moving servers as well, or just pointing the new domain to the same server? because I noticed you said ".com" and ".net". I'm currently running WP on root, and my forum on /forum, so it shouldn't be an issue at all. Obviously if you are changing servers, you'd have to go through the process of the transfer, but that's about it.

    mauwiks
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Since you are changing the domain, I would assume that all users will be logged out, since the so called Transient Key, Vanillas session identifier, is stored in the cookie that cannot be seen from your new domain.
    You should clean the files in the /cache/Smarty/compile folder, but beyond that I don't expect any problems

    mauwiks
  • I already made the move. I just used the Softaculous on cPanel and it worked fine at my end I guess. Thank you for your comments!

  • When I create a new account in WHM no subfolder for domain.com is created. This makes quite a mess when you add numerous addon domains, especially when you use something like WordPress on the main account domain, as it's full with WordPress folders AND addon domain folders, eg:

  • @zonmo2 said:
    When I create a new account in WHM no subfolder for domain.com is created. This makes quite a mess when you add numerous addon domains, especially when you use something like WordPress on the main account domain, as it's full with WordPress folders AND addon domain folders, eg:

    Sorry, but what has that to do with Vanilla Forums? Shouldn't that be posted in either the cPanel forums or WordPress Forums?

    Since it is not a WP issue, I suggest you complain about that on the cPanel forums

    mauwiks
Sign In or Register to comment.