Please upgrade here. These earlier versions are no longer being updated and have security issues.

Manage Categories: Stranger Things

mirXmirX
edited October 2018 in Vanilla 2.0 - 2.8

Hi, guys! Managing сategories in dashboard I found pretty weird stuff. For a long time my forum had one category displayed as heading and several second-level categories displayed as discussions. Recently I updated Vanilla to 2.6.3 and tried to change the structure of the forum by creating new nested first-level and second-level categories and several third-level categories displayed as discussions. Some categories have been moved and deleted. The result was the following >:) :

  1. The "lost" categories appeared - they are not visible in the dashboard, but they are visible in the list of categories in New Discussion. I tried to delete the parent categories, but the "lost" categories migrate to another parent categories in this case.

  2. It was also found that all first-level categories (displayed as discussions) in New Discussion are not active and can not be selected. If these categories become second-level categories, it's possible to create new discussion in them. I have another test Vanilla forum 2.6.3 and there is no such issue there.

Note. All these first-level categories have not custom permissions.

Any idea why this might be and how to fix?

Thanks in advance.

Comments

  • I restored my forum from the backup made before editing the categories. The "lost" categories have have been killed, but issue 2 remains.

    (A) This is current structure - one category as heading and some subcategories as discussions.

    (B) New discussions can be created in all subcategories.

    (C) A new first level category ("Test") is created (displayed as a discussions) and the old subcategory ("Lex Mercatoria") becomes the first level category.

    (D) It is impossible to create new discussions in the first level categories Test and Lex Mercatoria.

    O.o

  • there is an older category as headings setting. This may be on.

    it used to be called "Display root categories as headings"

    and corresponds to Vanilla.Categories.DoHeadings configuration check for DoHeadings in your config.php file.

    grep is your friend.

  • you want to set this to false.

    grep is your friend.

    mirX
  • Thanks @x00 for reply.
    I found $Configuration['Vanilla']['Categories']['DoHeadings'] = '1'; in config.php and replaced '1' by 'false'. The cache has been cleared as well. Nothing changed :(

  • I tried to delete the entire string $Configuration['Vanilla']['Categories']['DoHeadings'] = '1'; and the issue was gone.

    Thanks again @x00 for your help. <3

  • Glad for it :)

    'false' is not the same as false, 'false' evaluates totrue as does any string.

    grep is your friend.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @x00 said:
    Glad for it :)

    'false' is not the same as false, 'false' evaluates totrue as does any string.

    'strange' :mrgreen:


Sign In or Register to comment.