Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Users can not login anymore with their credentials

Hi,

I updated Vanilla to 2.6.3 and PHP 7.2, and MySQL 8.0.12 on Windows Server 2016.
I've set Mysql to use the authentication method default_authentication_plugin=mysql_native_password; but users cannot log in with their existing credentials

Any ideas?

Comments

  • This is the error I am getting on the home page if I do not have the salt setting in the config file empty.

    The home page loads only when salt is empty $Configuration['Garden']['Cookie']['Salt'] = ''; and $Configuration['Garden']['Format']['Hashtags'] = false;

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    There has been a change between the password encryption and if you made a bigger update step, that might have been the reason for the passwords that were no longer functioning.

    Why do you update to 2.6.3 if 2.6.4 is available?

    At first you have talked about users not being able to log in, now you are talking about general home page problems.
    What has inspired you to delete the salt setting?

  • I was updating to 2.6.3 from 2.1.1 - fresh install of 2.6.3 and then importing the database of 2.1.1 and switching the database in the config file to point to that database. I ran utility update and utility structure but after enabling
    2.6.4 wasn't available at that time

  • In the configuration file of 2.1.1 the salt was empty
    but in the config for 2.6.3 has value
    The MySQL ini file I have set default_authentication_plugin=mysql_native_password but still in the database when I look the hash for new users passwords is almost twice the characters compare to the old users passwords

  • When I run utility structure it gives me this and I can not get rid of it - If I click Run structure and data scripts it says The structure was successfully executed. and if I run it again I get same Database Structure Upgrades

  • K17K17 Unkorneglosk - Français / French ✭✭✭

    Have you tried disabling all addons ?
    You should'nt manually edit the salt I think.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Those remainders from the structure are no problem and you can ignore them

    K17
Sign In or Register to comment.