Version 2.6.4 - install error

I am installing Vanilla Version 2.6.4. I carefully paste/type in all values for Database Host, Name, User etc. in the installer form but when clicking "Continue" I get the following error: Invalid log level: Failed to insert {type} ({content}): {error}.

PHP 7.2 - I even tried to go down to PHP 7.1 and PHP 7.0 but always the same error message.

The Webhost helpdesk had no explanation. Can anyone here decipher the error message and advise how to successfully complete the installation?

rasis

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited November 2018

    @Borum

    Welcome to the community.

    If you check this thread:

    https://open.vanillaforums.com/discussion/35688/invalid-default-value-for-dateexpires-vanilla-2-5

    Other users experiencing this had MySQL strict mode enabled, and it needs to be disabled.

  • Thanks for your reply! I once again contacted the Webhost helpdesk. Unfortunately, they told me that the MySQL's strict mode is permanently enabled. It is not possible to disable! Does that mean that I will be unable to install Vanilla! I have been using the Vanilla software for a discussion forum for almost 10 years. I would hate being forced to look for alternatives!

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Maybe someone will be able to help you, but my personal response would be to find a different/better host.

    I self-host for $6 a month. I was a little wary of leaving my host (Bluehost), but once I had, my only regret was not having done it sooner.

  • I fear that this will be the end of NaturNettet.dk. The Vanilla forum has served us brilliantly since 2009. I simply can't see how to continue after the update to PHP 7.2.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    What is stopping you changing hosts?

  • I have a number of domains all hosted by the same company that I don't want to move. However, I could consider placing the forum with another host and simply display it in a frame on the main site.

  • I followed your advice and installed the forum with another host. I use the EmbedFriendly theme and display the forum in a frame on my main site. It seems to work well. However, there are some issues re. date and time format, upload of pictures etc. I guess that I should start a new thread on each subject - if they have not been dealt with in the forum already?

Sign In or Register to comment.