Fatal error after importing database

I have tried moving my Vanilla (ver. 2.1.8p2) forum to a new server. I used phpMyAdmin to export the entire database and imported it to another host. After that I made a fresh Vanilla install (ver. 2.4.201) using the hostname, user etc. from the new server. When I tried to open the forum for the first time with index.php I got the following warning:

Fatal Error in Vanilla\AddonManager.autoload();

The error occurred on or near: /var/www/naturnettet.net/public_html/fracom/applications/dashboard/models/class.usermodel.php
4931: }
4932:
4933: /**
4934: * Checks if a url is saved as a navigation preference and if so, deletes it.
4935: * Also optionally resets the section dashboard landing page, which may be desirable if a user no

This is followed by a list called Backtrace and Additional information for support personnel

Unfortunately, I am unable to understand what to do in order to make it work.

Can anyone here help (I can copy/paste the additional information) or is the old database incompatible with the new Vanilla forum?

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @KristianB said:
    a fresh Vanilla install (ver. 2.4.201)

    It should be 2.6.4: https://open.vanillaforums.com/addon/vanilla-core
    Sounds as if you tried using the version from GitHub.

    First try installing 2.6.4 without using the old forum database. With that you can ensure that your server is capable of running Vanilla.

    After that is done, save the GDN_Role table of the new forum.

    Then change the database information of the fresh forum to point to your old database.

    Open "yourforum.com/index.php?p=/utility/structure" and "yourforum.com/index.php?p=/utility/update". Try that several times. Be patient. it should be enough.

    You might need to delete the table GDN_Role of the old forum and import the table from the fresh installation.


    mirX
  • KristianBKristianB
    edited November 2018

    Thanks for your reply!

    In fact, I did download the 2.6.4 from the website and installed it but when I look in the config.php it is identified as:

    $Configuration['Conversations']['Version'] = '2.4.201'

    I will, however, start all over according to your recommendation - probably within the next couple of days. I will let you know the outcome of my struggle!

  • Thank you very much for your most valuable help!

    I followed your instructions - made a fresh install - exported the new GDN_Role - imported the old database - deleted the old GDN_Role - imported the new GD_Role ... and tried a couple of times to run ...utility/structure and ...utility/update. After a few disappointing errors, the update all of a sudden claimed to have been completed successfully. And all discussions and posts from the past 3½ years again appeared in the forum - exactly as before!

    Once again, thank you very much! Without your help, I wouldn't have been able to make it. I have absolutely no knowledge about creating and editing databases but now I feel to understand a little about how it works.

    R_J
  • wjcroftwjcroft William J. Croft / Mount Shasta, CA / OpenBCI forum admin New

    Hello @R_J and @whu606,

    Question on a hitch in the "jumping" upgrade method you suggest, from our current forum running 2.1.8p2 to 2.8.4. Without going through intermediate versions.

    I'm trying to follow similar steps as shown in this thread and the other related one, you have posted on:

    open.vanillaforums.com/discussion/36346/upgrading-from-version-2-0-18-1

    I am running on a test server and 2.8.4 installs / runs fine with an initially empty database. Then I edit the config.php to point to a copy of my current MySQL database. The forum/index.php?p=/utility/update says it completes ok, I run it a few times runs ok each time. Then as suggested I run utility/structure, but at this point it asks me to log in. None of my previous site logins work. So I cannot do the 'structure' step.

    I've tried both with and without the steps suggesting bringing in the 2.8.4 (clean install) tables (GDN Permission and Role) to my test copy of the current database. Still cannot login or run 'structure'.

    Any suggestions? Am I doing something wrong? I've tried logging in with several different usernames, including the name that corresponds to User ID 1. Still cannot get in.

    I'm also confused about bringing in Role and Permission from a 2.8.4 database to an essentially 2.1.8p2 database. Isn't this going muck up all the roles and permissions that have been assigned to users in the old database? Since different ID numbers are used?

    Regards, William

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    There have been a change in one of the older updates which requires everyone to reset the password. So I think you have to use the "forgot password" function.

    And you should directly update to 3.0


Sign In or Register to comment.