Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Private Conversations settings

ProtuneProtune New
edited November 2018 in Vanilla 2.0 - 2.8


On my forum, every username is allowed. For example names as Lovely= Crazy,. et cetera. Also usernames ending with a comma. In private conversations, de separation sign between names is a comma. So when I want to send a conversation to someone with username (for example) Saved, it won't work, because the name is ending with a comma. How can I change the separation sign in for example a +?

Kind regards.


  • Options
    R_JR_J Ex-Fanboy Munich Admin

    There is no clean way to do that. If you look at /applications/conversations/controllers/class.messagescontroller.php line 75 you find $to = explode(',', $this->Form->getFormValue('To', '')); which shows that there is no configuration value for that.

    Changing that value here will not be enough. There is also the JavaScript snippet that allows to add more users. In /applications/conversations/js/conversations.js line 91 you see author = author.split(","); where that character must be changed, too.

    To my understanding there should be at least a third code occurance where you have to change that, since all the user names are inserted to the form with the comma as the separator sign. I did not see it by doing the quick search through the code I did right now.

    But in order to make that work, you have to change the source code and that is always bad. You should disallow such silly names... =)

Sign In or Register to comment.