Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Memcached for Vanilla on Siteground

I want to share what I did, since I'm not actually sure what I'm doing. If someone correct me would be very apreciated. If everthing is correct then it could help others.

I was following instructions here: https://docs.vanillaforums.com/developer/backend/

Went to my cPanel and activated Memcached:

Then copy/pasted all the configurations to MyVanillaforum\conf\config.php

$Configuration['Cache']['Enabled'] = true;
$Configuration['Cache']['Method'] = 'memcached';
$Configuration['memcached']['Store'] = 'localhost:20103';
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_COMPRESSION] = true;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_DISTRIBUTION] = Memcached::DISTRIBUTION_CONSISTENT;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_LIBKETAMA_COMPATIBLE] = true;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_NO_BLOCK] = true;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_TCP_NODELAY] = true;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_CONNECT_TIMEOUT] = 1000;
$Configuration['Cache.Memcached.Option.'.Memcached::OPT_SERVER_FAILURE_LIMIT] = 2;

Notice I set the port localhost:20103, I think is safe to guess that 127.0.0.1 is the same to localhost.

Not pretty sure if my forum is actually faster now, is very small, but sometimes before I found it slow on some page requests.

On the section about "Advanced Handling of Headers" I didn't get a think what they are talking about, so I skipped that part.

I'll take a look to the Apache and nginx thing to see if I can do also something about without breaking my site

:)

Sign In or Register to comment.