2.7 installation issue with Yarn Package

Hi Folks,

Trying to run a composer install on the 2.7 branch and I get:

Installing core node_modules
yarn install v1.12.3
[1/4] Resolving packages...
[2/4] Fetching packages...
error https://registry.yarnpkg.com/flatmap-stream/-/flatmap-stream-0.1.1.tgz: Extracting tar content of undefined failed, the file appears to be corrupt: "Unexpected end of data"
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
Installing core node_modules failed

So the package in question has been removed from yarn due to a security issue. See https://github.com/yarnpkg/yarn/issues/6725#issuecomment-442395010.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Thanks for reporting that! Could you please open an issue on GitHub for that?


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If you go to the /build folder and run phing everything should be running smoothly, at least it did for me...


  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    This was a temporary issue with the NPM registry and that package. It was resolved shorty as it appeared in our CI builds.

Sign In or Register to comment.